App Store on my iPhone keeps on showing that there are 3 new updates, but when I click on updates, it shows 0 new updates.

It will update the badge count to 0 new updates as well, but not much later the 3 new updates will appear. See screenshots:

How can I get the correct badge count? It bothers me that the App Store says there are new updates, while there aren't.

iOS 6.1.3 / iPhone 4s

  • 2
    Having the same problem for days now. Hope Apple fixes this issue soon.
    – user58201
    Commented Sep 26, 2013 at 21:59
  • 1
    Same issue iPhone 5S iOS 8.1
    – mplungjan
    Commented Nov 12, 2014 at 19:01

6 Answers 6


I see that behavior for apps that require iOS 7. I'm still on iOS 6 and when going to Purchased -> All there is an Update button for apps that have an update available. When I tap the button the App Store suggests to install the last compatible version of the app.

  • 1
    Yes, it seems the badge counts includes the updates for apps that would require an update to iOS 7. Because I am still running on iOS 6 and not iOS 7, I would expect the badge count to include only the updates I can actually do.
    – ujjain
    Commented Oct 1, 2013 at 15:58
  • 1
    iOS 8.1 latest Twitter same issue
    – mplungjan
    Commented Nov 12, 2014 at 19:02

Thanks, bmike, for the theory. It allowed me to find at least one practical solution.

Go into the App Store. Select PurchasedAll. Now carefully scroll down the list. You will find one or more apps with a status of Install instead of Open. Go ahead and install them. If you have not upgraded to iOS 7 you may get a message that says that the latest version requires iOS 7, but you may download the latest compatible version. Touch Download and it will install.

These are the updates appearing in the badge count.

  • 1
    I tried this and got a dialog saying "The item you tried to buy is no longer available". Not sure what to do about this. There seems to be no way to remove items from this list. Commented Sep 29, 2013 at 8:07
  • 2
    Awesome, this solved my problem at least. Apparently there are some apps that are now ios 7 only and aren't automatically updated but they're not anywhere in the list anymore (except for the all list). Just a bug in ios 6 which probably won't be fixed anymore.
    – Wolph
    Commented Sep 30, 2013 at 9:03

This is a side effect of how iOS notifications work - or in this case, what happens when they don't work.

I see this sort of error on game center when the notification for a turn arrives well in advance of the actual game data.

It's kind of like when you check email and get a notification (and there you even get some data from the mail envelope - who sent it, date, subject), but the body of the email is still getting processed and send to your mailbox.

On the Mac app store side of things, I've seen this mismatch for hours and even in some cases days when the app gets hung up. The iOS app store is much more mature so I assume the server infrastructure is either coded more robustly or it has more resources and the delay between an update being signaled and actually available for your device to download is less.

As to how to fix it, you can't really send a reset to the app store app and need to wait it out.


Need to be a little patient. If you have different devices with different IOS like 6 and 7. AND SHARE THE ACCOUNT, the device on IOS 6 will keep updating the badge count for apps that it is trying to download that were purchased somewhere else or on another device. Go to the IOS 7 device first and do the Purchased - All thing like stated above. Then repeat on other IOS devices. This cleared the badge for me. I think its more of a communication thing in Notifications between the different IOS devices.....

  1. Open in iTunes on PC and download the latest version of the app that is causing the problem.
  2. On the iPhone, go to /var/mobile/aplications/"app name" and delete iTunesMetadata.plist

This bug happens because with the iOS 7 release there are different versions of apps for each OS (e.g. Evernote).

To find the app that is causing the problem, go on the App StorePurchased and scroll down until you see the app that has Update near, but will not update because you have iOS 6 or lower.

  • You mention deleting the iTunesMetadata.plist file through /var - this requires a jailbreak to navigate through the filesystem in this way… Can it be achieved through an alternative method? Also, you mention downloading the latest version of the app in iTunes - do you then need to perform a sync?
    – grg
    Commented Oct 14, 2013 at 17:04

No sync needed. You need to download the latest version of the app in the computer so it goes in the cloud and doesn't show as update when you access the App Store on the iPhone.

The other badge is from the app already installed on the phone. There is no way to remove that without deleting iTunesMetadata.plist (I think you can access the phone's root filesystem even without jailbreak using other applications on the computer).

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .