0

I have a Mac running Mountain Lion and an iPhone5 running iOS7

I have confirmed that the Apple account setup in messages in my Mac and iPhone are the same account.

However when I send a message to my wife's iPhone from my Mac it shows up as a separate thread (same name) than when I send a message from my iPhone. She will have 2 threads on her phone, when she responds to the thread started from the Mac, only my Mac will receive the message. When she responds to threads sent from my iPhone, only my iPhone receives the messages.

It like iMessage on my Mac vs iPhone are acting like 2 separate accounts even though they are both using the same Apple ID.

Is there anyway I can resolve this?

I tried followed the instructions here but there was no setting titled Use your Apple ID for iMessage. The settings may have changed since the last version of iOS I am guessing.

  • Which do you prefer - all devices sending as phone number or as email address? – bmike Sep 22 '13 at 2:02
  • As phone number. – JD Isaacks Sep 22 '13 at 3:04
1

When I went to Preferences > Accounts within Messages on my Mac under:

You can be reached for messages at:

It was only listing my email address (no phone number).

Logging out and back into Messages on my Mac, caused the phone number to show up here. Checking it fixed the problem and they are now synced.

  • Great answer. The other thing that messes up phone number is when the carrier is blocking SMS and iCloud is still waiting for activation ... See the first picture in this answer... apple.stackexchange.com/a/102407/5472 – bmike Sep 22 '13 at 3:34
  • I'm having the same issue however everyone else receives my messages from one user, except for a friend that receives them as two different contacts. Both are linked on that person's phone and it has made no difference – adolf garlic Feb 5 '15 at 11:08

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .