4

When I have new photos available in my shared photo streams, the iPhoto icon in the dock has a red circle with a number in it, also known as a "Badge App Icon".

I went to System Preferences -> Notifications -> Photo Stream and disabled everything, but the badge app icon on iPhoto still shows.

For now I have disabled shared photo streams completely from iPhoto -> Preferences, and that has removed the badge app icon, but I would prefer to still keep it enabled.

How can I disable this badge app icon?

0

2 Answers 2

1

I got rid of the red circle number (the notification), by going to system preferences ➔ iCloud ➞ and then unchecking the box to the left of "Photos" When you re-check the checkbox, the notifications will briefly display in the upper right part of the screen, telling you about photo stream invitations you have received from other people.

1
  • This worked for me too. I had an album that insisted it was new until I did this.
    – Mattie
    Jan 2, 2014 at 14:40
0

You can disable the badge on the Photos app icon in Notification Center settings. Go to System PreferencesNotificationsiPhotoBadge App Icon and uncheck the box.

System Preferences → Notifications → iPhoto

I don't have iPhoto on my system, so replace iCloud Photos with iPhoto.

4
  • As mentioned in my question, I tried this and it didn't resolve the problem.
    – Cory Klein
    Sep 22, 2013 at 12:20
  • Well, to be more specific, I tried it by disabling everything from "Photo Stream" in the preference pane. iPhoto doesn't even appear in the list.
    – Cory Klein
    Sep 22, 2013 at 12:20
  • @CoryKlein Yes, disabling the Badge App Icon for Photo Stream shouldn't do anything since Photo Stream isn't the app showing the badge… iPhoto should appear in the list though, as it is an app capable of showing notifications…
    – grg
    Sep 22, 2013 at 12:24
  • 1
    I heartily agree. I don't understand why iPhoto isn't in the Notifications preference pane either. Doesn't make any sense. Oh, Jobs, why did you have to leave us?
    – Cory Klein
    Sep 22, 2013 at 12:26

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .