2

I restored my iPhone 4s yesterday on my computer and it went through with no problems.

Today when my iPhone crashed and I tried to restore it again - I keep getting the message "This device isn't eligible for the requested build". Nothing has changed from yesterday - so I don't know why it was OK then but not now...

I've worked through the apple suggestions - no problems with the hosts file, no third party security software, firewall off, etc I've even tried it on another computer and I'm still getting the same message. It fails after the software is extracted (i.e. at the end of the first stage after I press restore) and it tries to verify with Apple...

Last bit of the restore log:
[11:33:28.4130] failed to personalize the restore bundle: This device isn't eligible for the requested build.
[11:33:28.4136] AMRAuthInstallDeletePersonalizedBundle
[11:33:28.4313] Restore completed, status:3194
[11:33:28.4313] Failure Description:
[11:33:28.4313] Depth:0 Error:Failed to copy auth install options in DFU mode.

Could the fault be on the Apple server side rather than mine or are there other things I should be trying?

  • Which Apple article are you using for your troubleshooting? We might be able to get you another step further if you can edit in some specifics. I'd be most interested in what results are logged in the iPhone restore log to see what step is hanging up. – bmike Sep 21 '13 at 17:28
  • How can I access the iPhone restore log? – wedge197 Sep 21 '13 at 21:21
  • Since the details you provide are lacking a bit in specifics, why not go through the troubleshooting guide and see what step is failing? * apple.com/support/iphone/assistant/restore – bmike Sep 21 '13 at 21:47
  • Can I assume you are not installing iOS 7 and instead are forcing iOS 6 to install? – bmike Sep 21 '13 at 23:15
  • yes - my latest back-up was done under iOS 6 so i didn`t want to run the risk of confusing things.... – wedge197 Sep 21 '13 at 23:22
3

Your problems are entirely on Apple's end. The message indicates that Apple no longer signing that version of software.

Yesterday, the code signing servers would sign the iOS 6 package you had downloaded on your Mac and let the device install that version of the OS.

Today, Apple is no longer signing that version of the software for that device.

I don't know how to say this other than Apple is forcing your hand to upgrade whether you are ready or not.

Had you used a jailbreaking tool to save the signature, you would have been able to replay that signing activity and possibly trick iTunes into restoring iOS 6. I wish I had better news, but you may have to jump to iOS 7 unless someone invents a new exploit to jailbreak iOS 6 in the absence of Apple's signing servers being cooperative with iOS 6.

  • Hmmm - that isnt great news... Does that mean that if I do update to iOS 7, when I then try and restore from backup, it wont let me, because my backup was done under iOS 6? Have I lost all my data/photos, etc because of this forced upgrade? – wedge197 Sep 22 '13 at 6:12
  • I think a restore backup should work, just not a restore iOS 6.x – psoft Sep 28 '13 at 5:02
  • Backup is fine... they are just forcing iOS 7 on you. The backup will install correctly afterwards. – unom Dec 7 '13 at 0:54

You must log in to answer this question.

protected by Community Oct 2 '13 at 13:52

Thank you for your interest in this question. Because it has attracted low-quality or spam answers that had to be removed, posting an answer now requires 10 reputation on this site (the association bonus does not count).

Would you like to answer one of these unanswered questions instead?

Not the answer you're looking for? Browse other questions tagged .