7

As a long time (intimately familiar with 3.11) Windows user I finally made the jump to OS X. I was excited to take advantage of the massive resolution on my new MBP, and it's as awesome as I thought it would be.

However, Unity + Windows looks terrible. I realize Windows was not built to take advantage of such jaw-dropping resolutions, but I still want it to run at native resolution. I find myself enjoying the OS X environment, and reluctant to leave it for a full screen Windows VM; Unity is becoming a must.

I've tried checking the 'Use Full Resolution' setting to no avail.

(Not sure if it makes a difference, but I'm running the Windows 8.1 preview)

How can I prevent Unity mode from displaying Windows in a clunky-looking, zoomed-in, pixelated view?

  • 1
    For a moment there I thought you were running Windows 3.11 in Fusion... with Unity. That would be something to see. – David Sep 20 '13 at 4:15
  • 2
    For what it's worth, I ended up going with Parallels instead. It handled this quite nicely. – Tanner Faulkner Nov 2 '13 at 18:37
  • 2
    How does it handle it? What's different? Does it scale up a low-res virtual screen, or use high-res fonts and Windows scaling, or...? – David Nov 2 '13 at 19:07
  • 1
    Looks like high-res fonts and Windows scaling. Not entirely sure though, it just 'feels right' and didn't require any fiddling. – Tanner Faulkner Nov 2 '13 at 19:30
3

I had the same issue with Windows 7 guest on a MBP 2013 retina display. It was solved for me by unticking the "Automatically adjust user interface size in Windows" checkbox.

enter image description here

1

I don't know if this is the answer you are looking for, but I have a 2013 13" Macbook Pro with 2 1920 x 1080 monitors attached. I'm running the newest version of Mavericks and windows 7.

At first when I was in unity, all my windows were huge and I couldn't figure out why. I tried to change the resolution of windows but that messed everything up and I had to exit and re-enter Unity to fix it.

But when I go Control Panel > Appearance and Personalization >Display, you'll see a window that talks about "Make it easier to read what's on your screen" and there are 3 options.

Smaller - 100%; Medium - 125%; Larger - 150%.

For whatever reason, mine started at the 150%, but choosing 100% makes everything fit and look the correct size for my screens.

  • I have the same setup, but my "Make it easier to read what's on your screen" claimed it was on "Smaller" setting already. I had to switch to Medium, log out/in then set back to Smaller and log out/in – abriggs Sep 11 '14 at 12:51

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .