0

I'm having difficulty managing music in my iTunes library on my phone. I have old songs that I do not want anymore that are still showing up with the iCloud symbol (ready to download) in my library. Even going to settings to hide certain downloaded music, the songs I do not want still appear (just without the iCloud symbol) and cannot be deleted. I want to completely get rid of some songs. Help.

  • 1
    Please can you update your question with details of your device/OS level etc. – stuffe Sep 19 '13 at 12:23
1

I was having the same problem. I went into Settings on my iPhone and to Music. Towards the bottom it says Show All Music. I just disabled that and it solved my problem.

0

At first, hide all iTunes Music tracks. Go to Settings > Music > Show All Music and turning it off.

Find the track you wish to delete and long-press the song cover and you'll be presented with options - one of which is to 'Delete from Library'. Tap on this option and you'll be asked to confirm the deletion. That's it.

-1

I had the same problem go to settings>music>show all music and slide the button over. Hope this helped!

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .