I upgraded to ios7 this morning, and now all my albums have their songs out of order. Does anyone know where the setting to change them back to album order is?

I can't find anything to indicate that shuffle is switched on (it does say "Shuffle" in the top right, but when I press it, it just changes to a highlighted "Shuffle All", which I don't think I want.)


2 Answers 2


Please use the

Settings -> General -> Reset -> Reset All Settings.

to reset your settings after the ios7 installation.

that should take care of your problem.

  • I did too. Got my tracks into order, but lost other info, including my wallpaper.
    – user57627
    Sep 20, 2013 at 15:04
  • @JohnColeman easy to recover your settings.
    – Ruskes
    Sep 20, 2013 at 15:12

This simple step fixed my song orders and left all my other settings intact.

“Reset iPad. Hold down the Sleep/Wake button and the Home button at the same time for at least ten seconds, until the Apple logo appears.”

Excerpt From: Inc, Apple. “iPad User Guide For iOS 7.” Apple Inc., 2013. iBooks. This material may be protected by copyright.

Check out this book on the iBooks Store: https://itunes.apple.com/us/book/ipad-user-guide-for-ios-7/id709634245?mt=11

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .