I have this used Mac Pro (mid-2010) that I recently bought, that came with OS X Lion installed. It was apparently installed from an image because there are a lot of installed apps and, though there is no extra data on the machine, I see various printers, accounts, network shares and the like when I open configuration dialogs. The seller also put a restore image on one of the HDs.

I have had a number of problems booting into various modes.

First off, I cannot boot into the Apple Hardware Test, either using D or Option-D. There is no .diagnostics folder in /System/Library/CoreServices. I have nothing but keyboard (PC, not Apple), mouse, monitor, and Ethernet cable attached directly to appropriate ports. No USB hub. It is common for Lion not to have the AHT on the HD but internet access to it should work but doesn’t.

I can’t boot into some of the optional modes.

Boot options that do work:

  • Safe Boot (Shift) - takes a long time and Verify Disk hangs system
  • Start from bootable media (C)
  • Reset NVRAM (Command-Option-P-R)
  • Eject removable discs (F12 key)

Boot options that don’t work:

  • Single User mode (Command-S)
  • Apple Hardware Test (D, Option-D)
  • Startup Manager (Option)
  • Recovery System (Command-R)
  • Open Firmware (Command-Option-O-F)

I know it is necessary to wait until the boot chime sounds before depressing the option keys, but I don’t hear the chime unless I reset NVRAM. When I do, I get the chime on the next hard boot but it disappears upon subsequent boots. So that is a problem. But I have tried resetting NVRAM, logging in, powering down, and doing a hard re-boot, and holding down the keys after the chime. In all the cases that don’t work, the system never boots and I have to do a force power-off.

I suspect this is probably a firmware problem but I’m not sure and could find little information about this problem.

I checked the firmware version and it is up-to-date.

system_profiler SPHardwareDataType | grep -i "Version" | awk -F ':' '{print $1 $2}'

  Boot ROM Version MP51.007F.B03
  SMC Version (system) 1.39f11
  SMC Version (processor tray) 1.39f11

I tried to re-install the latest version for this model, Mac Pro EFI Firmware Update 1.5 - Mac Pro (Mid 2010) MacPro5,1 MP51.007F.B03 (EFI 1.5) (http://support.apple.com/kb/DL1321) but it won’t install:

This software is not supported on your system.

Even though it already exists on my system.

I tried installing it from the Firmware Restoration CD 1.9 (http://support.apple.com/kb/DL1320) but I can’t get it to work. Holding the Power button as directed, the sleep LED blinks continuously for a second, followed by a single beep, not 3 quick blinks, 3 slow blinks, 3 quick blinks. The optical drive tray never opens and the system hangs. I tried manually inserting the disk in the drive first and then holding the button down, and also holding down C but neither of these worked.

Diskutil shows that the EFI partition exists and is 209.7 MB with 0 bytes used.

The EFI partition seems to be in order as per How to fix broken EFI partition?.

sudo gpt -r show disk0

start        size  index  contents
       0           1         PMBR
       1           1         Pri GPT header
       2          32         Pri GPT table
      34           6         
      40      409600      1  GPT part - C12A7328-F81F-11D2-BA4B-00A0C93EC93B
  409640  1952853344      2  GPT part - 48465300-0000-11AA-AA11-00306543ECAC
  1953262984      262151         
  1953525135          32         Sec GPT table
  1953525167           1         Sec GPT header

There is no firmware password set:

sudo nvram security-password

nvram: Error getting variable - 'security-password': (iokit/common) data was not found

When I first took a look at the firmware data I got:

nvram -p

boot-gamma  %ac%10%00%00*%a0%00%00SF01%b6%00%00%00%00%00%00%00%0d%00%01%01%e3%04%02%02%05%08%04%04)%0d%07%07%a1%13%0e%0e4 %18%18T/##%f8=00%a7M=='\NN%d7mrr%0b%90%9a%9a%90%b2%c9%c9%fb%d7%0d%00%01%01%e3%04%02%02%05%08%04%04)%0d%07%07%a1%13%0e%0e4 %18%18T/##%f8=00%a7M=='\NN%d7mrr%0b%90%9a%9a%90%b2%c9%c9%fb%d7%0d%00%01%01%e3%04%02%02%05%08%04%04)%0d%07%07%a1%13%0e%0e4 %18%18T/##%f8=00%a7M=='\NN%d7mrr%0b%90%9a%9a%90%b2%c9%c9%fb%d7

fmm-computer-name   user%e2%80%99s MacBook Pro
boot-image  %02%01%0c%00%d0A%03%0a%00%00%00%00%01%01%06%00%02%1f%03%12%0a%00%02%00%00%00%00%00%04%04%18%00d%007%00e%007%003%006%000%000%000%00%00%00%7f%ff%04%00

efi-boot-device <array><dict><key>IOMatch</key><dict><key>IOProviderClass</key><string>IOMedia</string><key>IOPropertyMatch</key><dict><key>UUID</key><string>#########</string></dict></dict><key>BLLastBSDName</key><string>disk2s2</string></dict></array>%00

After reset:

SystemAudioVolume   0
EFIBluetoothDelay   %b8%0b
fmm-computer-name   Mac Pro 2010

After re-start:

fmm-computer-name   Mac Pro 2010
EFIBluetoothDelay   %b8%0b
SystemAudioVolume   0
boot-gamma  %ac%10%00%00*%a0%00%00SF01%b6%00%00%00%00%00%00%00%0d%00%01%01%e3%04%02%02%05%08%04%04)%0d%07%07%a1%13%0e%0e4 %18%18T/##%f8=00%a7M=='\NN%d7mrr%0b%90%9a%9a%90%b2%c9%c9%fb%d7%0d%00%01%01%e3%04%02%02%05%08%04%04)%0d%07%07%a1%13%0e%0e4 %18%18T/##%f8=00%a7M=='\NN%d7mrr%0b%90%9a%9a%90%b2%c9%c9%fb%d7%0d%00%01%01%e3%04%02%02%05%08%04%04)%0d%07%07%a1%13%0e%0e4 %18%18T/##%f8=00%a7M=='\NN%d7mrr%0b%90%9a%9a%90%b2%c9%c9%fb%d7

What does boot-gamma do?

Another thing that’s missing is the Recovery HD partition and I can’t access the Internet Recovery feature because of the problem with the Command-R boot option. I was able to boot into a Mountain Lion install disk and access recovery tools but that doesn’t fix the problem. I don’t have Lion disks.

I made a CCC backup of the entire boot drive but I can’t test it because if it fails to boot I have no way to get back to the main boot disk because I have no access to the Startup Manager (Option).

I intend to wipe the disk and install Mountain Lion but I can’t move forward until I resolve these issues first.

Does anyone have experience with such problems? I have been searching for a solution for weeks now but have found almost nothing.


USE THE WIRED KEYBOARD - Maximus put me on the right path - my iMac wouldn't respond to the startup key sequences using the Bluetooth keyboard; the wired keyboard worked perfectly. My DVD drive doesn't work, so I tried making a bootable usb hard drive and then a bootable usb flash drive from my Snow Leopard Installation DVD, and couldn't get the iMac to see either of them, I thought, when actually the problem was the iMac wasn't seeing the startup key sequences from the Bluetooth keyboard. Something so simple...


Safe Boot (Shift) - takes a long time and Verify Disk hangs system

If you mean that safe boot does not complete – if you mean that the disk verification stage of safe boot is truly endless:

  • whilst limited to Lion, you'll probably not find a workaround or solution for that bug.

Please see:

Open Firmware (Command-Option-O-F)

That's probably not applicable to an Intel Mac.

keyboard (PC, not Apple)

What make and model?

Is it wireless? Please be aware that there's a known issue with at least one Apple keyboard that uses Bluetooth.

  • 1
    Hi, you guys do realise that a PC keyboard doesn't have the necessary firmware to support all commands in EFI? – Maximus Dec 15 '13 at 20:21

It's extremely strange that you were not getting EFI boot options to work from a wired keyboard.

I note that the EFI startup commands you listed that worked used either the Shift key modifier or the Option AND Cmd modifier. The commands that didn't work used either Option OR Cmd. Makes you wonder...

You do know that the keys that generate "Option" and "Cmd" keycodes are typically reversed from a PC to a Mac keyboard, correct? (It's easy to forget if you normally have them remapped in System Preferences->Keyboard.) Is it possible you were using the wrong modifier keys at startup time?

Also very strange that the nvram dump shows your desktop machine had been assigned a name that implied it was previously a laptop. If the previous owner used some sort of imaging tool to initialize your machine but took the image from a different model of Mac I can imagine all sorts of strange things could be going wrong.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .