5

I made a stupid 802.1X settings file some time ago to test some things. Now I am unable to remove it, even though I think I have deleted the file.

The picture below shows the 802.1X profile to the bottom right. How do I delete this profile? I've tried removing the ethernet with the minus sign in the left menu, but once I try to make a new ethernet profile, that 802.1X setting shows up as the standard.

enter image description here

Here is the picture of the 802.1X settings: enter image description here

1

The 802.1X configuration is protected with Keychain.

To remove it, select a network configuration which isn't using your 802.1X setting.

Then open Keychain Access (within Applications/Utilities).

Unlock it. Select the login keychains, and search for labsenteret_peap which should be of kind 802.1X Password.

Select it, remove it.

Quit Keychain Access.

Modify your network configuration.

And to help you manage these network configuration in the future, give it a name better than Location (9/13/12 9:48AM). For example: lab. connection / Ethernet

  • Cannot test this due, but accepting until sb comes up with something better. Thanks. :) – The Unfun Cat Aug 9 '16 at 8:39
  • Why can't you do it? Please, don't vote for my answer as long as no one tested it with Mountain Lion. I can't because I dont use Mountain Lion anymore. – dan Aug 9 '16 at 11:59
8

Try System Preferences > Profiles. It listed my 802.1X profiles and I was able to remove them from there.

Alternatively, you can manually edit configuration files in /Library/Preferences/SystemConfiguration (see this post) - grep the files located there for the name of your profile.

(Using OS X Mavericks)

enter image description here (Profiles is located in the second row from the bottom)

  • 2
    Where did you get System Preferences > Profiles? I don't see it on Mavericks & Yosemite. – dan Aug 9 '16 at 12:01
  • See my updated answer – Mifeet Aug 9 '16 at 13:02
  • The /Library/Preferences/SystemConfiguration solution works in macOS Sierra as well. The file in question was com.apple.network.eapolclient.configuration.plist in my case. Emptying the file (after a backup) and restarting macOS did the job. – fbmd Jul 5 '17 at 13:50
1

If you open the dropdown, you can choose edit, there you can create a new location. In the new location, all settings should be on default, so your 802.1X setting shouldn't be there anymore.

  • If you open the dropdown, you can choose "edit", there you can create a new "location". In the new "location", all settings should be on default, so your 802.1X setting shouldn't be there anymore. – Kevin Grabher Mar 29 '14 at 13:16
1

I had the same issue and followed the advice to grep eduroam in /Library/Preferences/SystemConfiguration.
The file I had to modify was com.apple.network.eapolclient.configuration.plist. In this file you can actually see, the migrated profiles.

0

What you are doing when you click the minus sign is disabling the ethernet port completely. Instead, I think you want to remove an 802.1X configuration.

If you click the Advanced... button, a sheet will display with various tabs across the top. One of those is 802.1X

On the left side of the 802.1X display, you can add or delete profiles.

Screenshot of 10.6 Network settings This screenshot is from 10.6.8; but, the principle is the same for 10.8

  • I added a picture to show what it looks like in 10.8 – The Unfun Cat Sep 17 '13 at 10:08
  • Oh... looks like I spoke too soon. I don't know where the profile's minus sign went to in 10.8 What happens if you control-click (right-click) the profile in your list? – Kent Sep 17 '13 at 10:11
  • Nothing happens. – The Unfun Cat Sep 17 '13 at 10:12
  • You might try this: support.apple.com/kb/PH11323 It seems Apple has moved the configuration out of the Networks pane and into the Profiles pane? – Kent Sep 17 '13 at 10:22
  • @TheUnfunCat please make a screenshot with Command-Shift-4, release the keys, then press the spacebar and click the window. This hurts my eyes! in detail – CousinCocaine Sep 17 '13 at 10:33
-2

I just Restarted my Laptop, and it was back to normal again.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .