4

I'm having some issues with my MacBook Air (2013). Whenever the system enters hibernation, as it does after a couple of hours of sleep, the screen gets distorted when it comes back from sleep.

When resuming from sleep the screen gets distorted like this:

Artefact1

Artefact2

Artefact3

A reboot fixes that but the menu bar icons as well as some toolbar icons disappear, like in the following screen shots:

Menu bar:

Menu Bar

Finder:

Finder

Mail:

Mail

These issues go away with a reboot into safe mode and then reboot (a tip which I found in a different thread here), however it all comes back after the next hibernation.

It seems to be power related, as it only happens if the power cord is plugged in when the computer first goes into deep sleep and then gets plugged out while in sleep. I've tested this thoroughly using the DeepSleep widget and found how to reproduce it.

I've tried resetting the PRAM but no luck there. Also, the return from pmset -g | grep hibernatemode is 0 - is that normal on the Air? It used to be 7 on my previous MacBook.

Another thing that might be worth noting is that this started happening after I ran out of battery while the computer was on, however it happens every time it sleeps without power cord since then, even though it doesn't run out of power.

Update:

I thought that changing the hibernatemode to 7 worked, since my test to reproduce the issue didn't cause it anymore. However after having had the computer sleep over night it wouldn't wake up, it just showed a blank screen. This is the console output I got: http://pastebin.com/EB4SAtfe

The logs at 01:52 is when I put the computer to sleep and went to bed. It then wakes up 3 hours later and is then supposed to sleep again I guess. Not quite sure why it does this, it also says:

2013-09-16 04:52:53,008 com.apple.time[13]: Next maintenance wake [Backup Interval]: <date: 0x7fb250608870> Mon Sep 16 02:03:30 2013 CEST (approx)

Although that time has already past (It's 04:52 CEST when it schedules that). Also, there is no console output from when I wake the computer, even though I waited a good couple of minutes at the black screen before forcing a reboot as well as closed and reopened the lid.

  • could you post a console record of the activity during sleep mode, including the moment when you unplug the power. – Ruskes Sep 15 '13 at 17:25
  • Setting hibernatemode to 7 seems to have solved it. Since unplugging the power wakes the computer (Wake reason: EC.ACDetatch) my guess is that the sleepimage gets corrupted. When I wake the computer it loads the corrupt file and that explains the garbling. Does not explain the missing icons though. – Rick Sep 15 '13 at 18:51
  • I'll wait a few days and see how it works, not sure if it's stable. – Rick Sep 15 '13 at 22:50
  • Still having issues, updated with console log – Rick Sep 16 '13 at 9:28
  • 1
    Also maybe worth noting: The garbling appears on screenshots as well. – Rick Sep 17 '13 at 9:00
2

So here's what happened:

I took the computer to the AppleStore, seeing it was only about three weeks old, and got them to take a look at it. Since it's a company computer I had some company benefits granting me a temporary replacement while they were fixing mine. I took my TimeMachine copy and restored it on to the borrowed Mac. I was surprised to find that the issue still appeared, which was quite annoying. So I restored the Mac again, messed around with the pmsetsettings and tried to reproduce the issue but it was impossible.

I then remembered that the issue started appearing a few days ago when I did a battery calibration (Drained the Mac completely) so I restored to a TimeMachine backup from before that and Boom, the issue was gone. At about the same time they called from the store and said that they couldn't reproduce the issue, so I told them what I had found, came in and got my computer back.

All in all, a really weird story but apparently something related to draining the battery while the computer was still on got corrupted and was then included in the TimeMachine backup.

0

Are there any relevant messages shown by pmset -g log or in system.log?

I think that pmset -g hibernatemode should be 3 by default on laptops both on battery and AC power. man pmset says that "standby only works if hibernation is turned on to hibernatemode 3 or 25". What does pmset -g standby return on battery power or AC power? Did you start using the Deep Sleep widget before or after those issues started?

Since starting up in safe mode fixed the issues, have you checked if Disk Utility shows some errors when you verify the OS X volume, or have you tried deleting /var/db/dyld/?

I had a similar issue on my MacBook Air where toolbar icons and other icons occasionally disappeared, but it stopped happening after I reinstalled OS X from the recovery partition. The screen was never distorted after waking up from sleep though. In any case, you could try reinstalling OS X: it only takes about an hour if you have a fast Internet connection, it keeps user files and settings in place, and it might also fix other issues. Upgrading to 10.9 might have the same effect though.

  • reinstalling the os, is not addressing the problem. – Ruskes Sep 15 '13 at 17:22
  • @Buscar웃 It's easy enough that it can be done as a troubleshooting step though. – Lri Sep 15 '13 at 20:54
  • I did not say it is not easy, just it is bit like doing major surgery, for a common cold. – Ruskes Sep 15 '13 at 21:00
  • Thanks for the reply. As mentioned in my updated post now I tried pmset 7. I also tried 3, but with that it wouldn't go into hibernate at all. 3 and 7 should be the same with the difference that 7 is for secure VM. pmset -g standby returns nothing but pmset -g | grep standby gives me: standbydelay 10800 standby 1 (Not sure if that's what you meant) I used the deepsleep widget only to reproduce the issue without waiting 3 hours with the computer in sleep mode :) – Rick Sep 16 '13 at 9:40
  • I tried hibernatemode 3 but that causes the same artefacts and missing icons after reboot. Did a repair permissions in Disk Util and that changed some permissions but it didn't help. – Rick Sep 16 '13 at 9:52

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .