1

I'm on my neighbours WiFi, and connecting to my network to my Windows 7 PC which is set up as a VPN server using the native feature. I can access my Time Capsule by going to Connect to Server and entering it's IP Address, but it does not show in Finder automatically, in the Shared section of the sidebar. Also when I'm actually connected to my home network my Raspberry Pi appears in the sidebar, but when I connect over VPN it doesn't.

Is there a way to get the network shares to appear automatically in Finder over a VPN connection?

1

Usually the sidebar shows Network Devices which are announcing themselves and are recognized by the 'Bonjour'-Service. For that to happen the appropiate Ports have to be used, in case of the 'Bonjour'-Service that would be Ports 1900, 5350, 5432 and 5353 (see "Well known TCP and UDP ports used by Apple software products")

My first suggestion would be to check your VPN-Server if these ports are blocked, which would prohibit the Devices showing up in the sidebar.

If the Raspberry is an SMB-Share you can try the following steps:

  1. Open System Preferences » Network
  2. Click the network interface you use for the shares (that probably should be your WiFi Connection rather than the VPN-Connection. You have to try both eventually)
  3. Click on the Advanced button at lower right
  4. Click on WINS tab, and manually enter the workgroup name of the server
  5. Click the '+' under the WINS Servers list
  6. Enter the IP of the server
  7. Click OK, Apply, etc.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .