2

I am trying to get AVIDemux set up with the X264 codec using this tutorial. The following is what goes down when I get to the ./configure --enable-mp4-output command

Thomas-Phillipss-MacBook:x264 tomdabomb2u$ sudo ./configure --enable-mp4-output
Password:
Unknown option --enable-mp4-output, ignored
Found no assembler
Minimum version is yasm-0.6.2
If you really want to compile without asm, configure with --disable-asm.

So I tried it.

Thomas-Phillipss-MacBook:x264 tomdabomb2u$ sudo ./configure --enable-mp4-output --disable-asm
Unknown option --enable-mp4-output, ignored
Warning: gpac is too old, update to 2007-06-21 UTC or later
Platform:   X86_64
System:     MACOSX
asm:        no
avs:        no
lavf:       no
ffms:       no
gpac:       no
pthread:    yes
filters:    crop select_every
debug:      no
gprof:      no
PIC:        no
shared:     no
visualize:  no
bit depth:  8

You can run 'make' or 'make fprofiled' now.

I issued make, and then Thomas-Phillipss-MacBook:x264 tomdabomb2u$ ./x264 -v -q 20 -o foreman.mp4 foreman_part_qcif.yuv 176x144. And as expected, the results are:

x264 [error]: not compiled with MP4 output support

So I'm stuck. Any ideas?

3 Answers 3

1

That's a pretty old tutorial. Try this one (linked from the official Avidemux site).

1
  • The tutorial you've linked to doesn't mention this issue - are you expecting it to fix something specifically or is it just a guess?
    – PandaWood
    Jan 26, 2011 at 9:57
0

Fast solution:

  1. If you have x264, don't worry about un-install. Stay with it.
  2. Check your assembler yasm verison.
  3. Install gpac --> from svn.code.sf.net and compile it.
  4. Copy gpac/inlucde/gapc/ into x264
  5. inside x264 and configure as follow

    ./configure --extra-ldflags=-L/home/../gpac/bin/gcc --enable-mp4 --enable-shared --enable-debug --enable-PIC 
    
  6. You get the list in the configure x264 and you can easily find that your MP4 from 'no' changed to 'gpac'
  7. Enter make
  8. Enter make install
  9. Write x264 command as x264 big_buck_bunny.y4m -o big_buck_bunny.mp4 to test it. Now you have mp4 video. In this process it's not necessary to convert raw video to h264 and then in a second step with another tool to mp4.
0

Installed the latest version at http://nasm.us in /usr/local/bin/nasm, ran ./configure again, fixed.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .