4

I'm using Terminal and don't know if this has been an issue after upgrading to Mountain Lion, or whether I made a configuration change that had a side effect that I didn't realize. When I use the CMD + SHIFT + ] or CMD + SHIFT + [ keys, the mac beeps at me instead of switching the tab I'm using in Terminal.

Is there a way to remap this sequence? Where would I look?

Note, I can use CMD + SHIFT + ] / [ to shift tabs in Safari and Chrome, so this only happens in Terminal. (I also noticed that CMD + 1, shifts desktops instead of shifting to a particular tab; I'm okay with that not operating as I would expect since I don't use that shortcut).

Note, I have switched my CMD & ALT keys on my keyboard, but if I use a keyboard without these switched, I get the same behavior.

3

Edit: Disregard the first part. [ Is the shift of { so we were saying the same thing different ways. I'm leaving this here though regarding disabling the Mission Control shortcuts.

The sequence to cycle forward through tabs is +shift+}, despite what the Window menu says. (+} switches between windows. Very odd.) And +shift+{ cycles backward.

Terminal's Window menu with incorrect keyboard shortcuts displaying for cycling tabs

(You should also be able to reclaim +1, +2, etc. to switch windows in Terminal, which is what the Window menu says those shortcuts do, by going to System Preferences > Keyboard and disabling the keyboard shortcuts that use cmd+ a number under Mission Control. I haven't tested this though.)

System Preferences > Keyboard Preference Pane

  • Ok, This indicates the issue. I'm using MacOS in Swedish. It's making an assumption that I'm using a Swedish-keyboard and the mappings are CMD + Ä and CMD + Ö. I'm using an English keyboard. Is there a way to change the shortcuts for the select next and previous tab. – J. Fritz Barnes Sep 12 '13 at 21:19
  • 1
    System Preferences > Keyboard > Keyboard Shortcuts tab, click on Application Shortcuts on the left, then under the right window click the + button. Choose Terminal from the Application drop-down menu (hint: you have to go to the bottom of the menu and select Other, go into the Utilities folder, and select it there), for Menu Title enter Select Next Tab, click in the Keyboard Shortcut field and press the keyboard combination you want. Repeat these steps, except the second time enter Select Previous Tab. – tubedogg Sep 12 '13 at 21:31

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .