2

Today, I received from Amazon a Thermaltake BlacX 5G hard drive docking station and a 2 TB Western Digital Green drive. I inserted the drive and was able to format it into a one partition drive.

I then started a clone backup in SuperDuper which stopped when the drive seemed to eject itself. I reinserted the drive and was told it was not formatted. I began to reformat it and received the "File System Formatter Failed" error message. I rebooted, tried the docking station on a different USB port, etc. None of it worked.

I then tried to format the drive via terminal and received the following:

AndyMBP:dev andy$ diskutil eraseDisk HFS+ clone disk3
Started erase on disk3
Unmounting disk
Error: -69760: Unable to write to the last block of the device
AndyMBP:dev andy$ 

What I am trying to figure out is whether I have a bum drive or a bum docking station. Is there a way to determine this short of buying another drive? Everything is under warranty, but I want to make sure I return the correct item.

1

Try using some other means of connecting to the drive other than the Thermalake docking station. I had the same problem with one awhile back. I ended up using a plain ol' SATA to USB cable and that fixed my problem.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .