0

I am having difficulty troubleshooting this error message:

enter image description here

I don't get any indication any details about the failed connection attempt.

How can I diagnose such timeouts and resolve the connection issue?

I am aware of and have tried methods like rest your airport, reset the computer, delete profiles, down to install new operating system and rather than have people guess (and then vote for) specific causes like has happened on this thread, I'd like to know how to pick apart the connection process to know where the problem lies.

When I successfully connect, system information has excellent details:

enter image description here

However, without changing anything, at a later time, I will time out again when joining. Can I see the details of the process for the connection and find what is making it fail? What would it take to create or access a log file of the wifi connection process?

3
  • I understand your frustration, nevertheless I've heavily edited the question to focus on the problem you are facing. Most probably others had similar experiences, let's see what kind of answers we can get.
    – nohillside
    Sep 11 '13 at 17:46
  • There seems to be many causes of this error… Could you add some details: 5GHz or 2.4GHz? Do you get this error when you try to connect to a network initially or whilst you are connected? Is WiFi your only connection or are you connected using Ethernet at the same time? Have you tried deleting the WiFi setting in System Preferences and starting again? This post on OSXDaily.com might help…
    – grg
    Sep 11 '13 at 17:46
  • And this here looks very similar with a bunch of good ideas in the answer sections. Can you give those a try or edit this so it's clearly a different question than the one asked? That edit will dump this into the reopen review queue so it can be evaluated once changed.
    – nohillside
    Sep 11 '13 at 17:48
0

Don't have the solution but have interesting observation!!

My WiFi scan shows the SSID that I want to connect to

enter image description here

and in Terminal the Airport -s shows same SSID

enter image description here

I was monitoring the Console during the event.

enter image description here

The Associate event still shows the Correct SSID

<airportd[535]> associate: INFO: airportd associate: network=<CWNetwork: 0x7fec12802ce0> [ssid=Eurona900850808-81, bssid=02:0c:42:39:95:94, security=Open, rssi=-80, channel=<CWChannel: 0x7fec12802cf0> [channelNumber=7(2GHz), channelWidth={20MHz}], ibss=0], is8021X=0, remember=1

After few lines of other WiFi activity this comes up:

<kernel> Searching for networks with ssid Eurona900850808-8

WAIT: where did the last digit go, it supposed to be the Eurona900850808-81, but it shows Eurona900850808-8

Here is the rest from the Console:

Fri Sep 13 23:22:55.92  <kernel> Searching for networks with ssid Eurona900850808-8
Fri Sep 13 23:22:57.488 <kernel> No networks found. Please check if the network exists and is in range
Fri Sep 13 23:22:57.488 <airportd[535]> _WiFiMT_LogAssocTimeoutFail: MT** Assoc Timeout
Fri Sep 13 23:22:57.488 <airportd[535]> associate: Apple80211Associate2() failed with error -3905

Clearly the SSID lost the last digit somewhere in the process, and that leads to the Famous Timeout Error at least in my case.

While Apple provides great tools to analyze the WiFi, it is lacking bit more descriptive Error messages, like in my case saying there is no such network available since it clearly knows that in the Console report.

0

I got this attempting to connect to a new network, where the response was a dialog box with the "Connection timed out" message. I ran airportd logger and got :

associate: Apple80211Associate2() failed with error -3905

I found that this was due to the fact that I was using WPA to attempt to connect to a 802.11n network that was previously undiscovered. I also kept getting :

Received Disassoc from 00:02:6f:e6:ee:a0 with Reason 14

I've found nothing documenting either airportd error codes or kernel Disassoc Reason 14, anyway.

When I manually added the network to my preferred networks and set the security to WPA2 Personal, it found and connected to the network.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .