2

In the AirPlay device list, the name of the hosting computer is always "computer", independently of the computer's actual name.

Is there any way to set this string to a more "expressive" name?

EDIT

Setting the host name in the sharing section of the "Systems Preferences" does not work, as the following images demonstrate:

Mac: host

iPad: enter image description here

  • On which device are you looking at the list? – nohillside Sep 9 '13 at 10:01
  • I've looked from the host itself and from a iPad via the Remote app. – Matthias Sep 9 '13 at 10:24
3

Here's what I did to rename the Computer label in the list of available AirPlay speakers in iTunes.

  1. In Finder, go to your Applications folder.
  2. Hold the control button and click on the iTunes icon. You'll get a pop-up menu.
  3. Choose Show Package Contents from the pop-up menu. You should now see a Contents folder in your Finder window.
  4. Use Finder to navigate to the Contents > Resources > English.lproj folder.
  5. Open the Localizable.strings file in a good text editor.

    You may want to make a backup copy of Localizable.strings before going any further!

    TextEdit isn't good enough. It'll show you gibberish. I used TextWrangler, which is free.

  6. Use Command+F to search for pb7r8smvm5. You should see two lines that look like this:

    <key>pb7r8smvm5</key>
    <string>Computer</string>

  7. Change Computer to whatever label you want (e.g., Living Room).
  8. Save the Localizable.strings file.
  9. Quit iTunes and then open it again. Your new label should appear in the list of speakers.
These instructions are for Mac OS X. Windows instructions are available.

1

Go to Systems Preferences -> Sharing and edit your computer name.

enter image description here

From your iOS device, this name will display when you use AirPlay:

enter image description here

  • Thanks for the answer, but a setting of the name in sharing does not work, see edit. – Matthias Sep 9 '13 at 19:17
  • Odd. I change it in mine, and it changes to the new name. I tried it on another Mac on my network, and it works on there as well. – Dave Sep 9 '13 at 19:43

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .