0

Just recently, my MacBook Pro (Mountain Lion 10.8.4) will no longer go into sleep mode. When I press Cmd+Option+Eject, the screen goes black for just a second but then comes back on. If I close the lid, the screen turns off but the system remains on.

I'm pretty sure this started after running uTorrent, which has an option to prevent sleep while a transfer is running. However, I've disabled that option now, but the system still won't sleep.

When I run pmset -g in the terminal, there is a line that says:

sleep                120 (sleep prevented by )

I think there is supposed to be a PID listed there, but it's just blank, which makes me wonder if I've hit some bug that corrupted a system setting that needs to be reset.

Sleep is prevented after a clean boot, with all non-system disks ejected, no external monitors, with no third-party programs running (even Dropbox and Evernote daemons).

  • Sleep is prevented by a app or hdw that the shutdown can not confirm to shut down. In that case the system stays on waiting for you to take action. However in some case there is no Error message for you to know what to do. In your case look at the shutdown log (in the console) and for something that did not confirm the shutdown--or publish your log here. – Ruskes Sep 8 '13 at 21:04
  • FYI, in some instance it could be the USB host controller not been able to shut down properly (even without external units connected). As you know, just unplugging external units sometimes does not properly report that to the system. To verify that just before shutdown, look in your Apple system info and under the USB to see if something is reported to be connected. – Ruskes Sep 8 '13 at 21:05
1

in terminal try running :

syslog |grep -i "Wake reason"

Also what other steps have you taken to resolve the issue?(pulled plist, try in another user account, etc)

Sorry I don't have enough rep yet to comment on the question.

0

Ah! I forgot, I had also enabled Internet Sharing, to bridge my wi-fi connection to wired ethernet. I can understand why that might disable automatic sleep, but it's really annoying that it prevents me from manually sleeping.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .