2

We have set up parental controls on a child account to disable all but whitelisted applications from running. The problem is that now when the child first logs on we get repeated dialog boxes along the lines of "You don't have permission to use the application XXX" where XXX is things like "Kodak EasyShare" and "HPScanner". The problem is that as soon as we click "Ok" another dialog box pops up about 5 seconds later. After a while it amount of time between popups seems to decrease, but it never seems to go away.

How can I disable this dialog popping up? It makes the account nearly unusable!

2

You can disable the startup items entirely, so they don't attempt to run at login.

System Preferences → Users & Groups → (Kid's account) → Login Items

Select the applications that are denied, then click the minus sign to remove them from the boot process.

See also: http://www.maclife.com/article/howtos/how_remove_startup_items_os_x

  • The processes that keep popping up don't show up in this list. In fact, there is only one item in this list, and it is already disabled. Today it's "UserNotificationCenter" – Michael Dec 28 '13 at 17:08

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .