1

I'm running 10.8.4 on a MBA, and I've run into a little inconsistency in Finder's behavior. I have two accounts on my machine, an admin account and a user account. In both accounts I have Finder set to open new windows in the home directory in column view.

If I open a new window and try to select a subfolder with a keystroke (eg. D for Desktop), it only works in the admin account. In the user account it seems to be interacting with the home directory's enclosing folder instead of its subfolders. So if I type S it selects /Users/Shared rather than /Users/user/Spoon.

I know it's a small thing, but it messes with my workflow, and I'd like to know why the inconsistency. Any ideas?

Update: I tracked down the cause, with a little help. Someone recommended I look at System Prefs > Keyboard > Keyboard Shortcuts. I did, and noticed the Full Keyboard Access radio button at the bottom of that page, where you choose whether the Tab button cycles through all controls, or just Text boxes and lists. I remembered that I'd set it to "all controls" in the standard user account, but not in the admin account. Sure enough, changing it back to the default "Text boxes and lists only" fixed the behavior.

  • Interesting fix. Good work solving that... – beroe Sep 10 '13 at 4:45
  • @beroe Thanks. It's a little unfortunate, since I like being able to use Tab, especially for the buttons on pop-up dialogues. With Tiger (my last OS) I was able to do so without the above problem, but oh well. – ivan Sep 10 '13 at 14:06
  • I was testing on my machine. Don't you navigate the correct folder even on afflicted machines if you push the right-arrow from the new window? An extra keystroke, but you could have your tab behavior also... – beroe Sep 10 '13 at 14:39
  • @beroe True, that works. Call me lazy, or just set in my ways :) I guess it depends which situation I encounter more, and weighing that extra keystroke against all the mousing that Tab can eliminate. – ivan Sep 10 '13 at 17:21
1

Just a thought, but do you have Show Hidden Files turned on in the User account and not admin? Could paste this in a terminal window:

defaults write com.apple.Finder AppleShowAllFiles NO

and see if it makes a difference.

  • No dice, I don't have either account showing hidden files. Not a bad thought though. – ivan Sep 8 '13 at 19:49
  • Interesting. You are sure that in the Finder Prefs (the Command-comma one, not Command-J), both say "New Finder windows show [your home]?" Seems weird that the plain user window would show "higher-level" files. Maybe try re-selecting that folder from the options. – beroe Sep 9 '13 at 3:49
  • I know, it's weird right? The home directory is definitely selected in both accounts' Finder Prefs (⌘,), and I've tried reselecting it in the standard user account, to no avail :( – ivan Sep 9 '13 at 14:22

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .