1

When I want see movie or video in mac os x (with VLC, DivX Player, Quick Time) and want to load subtitle these video player application can't load my subtitle correctly and show in strange text.

my subtitle languages is Farsi (rtl language). I think I must change some unicode settings but I don't know where anyone have any idea?

alt text

2

According to Trezoid answer on superuser the solution is:

By default the language encoding on VLC (and possibly others) is set to "default" which is windows-1252 (possibly only if your language is set to english, but I'm not sure)

This will not display other languages very well. To fix it, open up VLC preferences, click on the Subtitles and OSD tab, and change "default encoding" to UTF-8

This will give the program a much wider choice of characters to display from allowing it to render the characters as they should be.

2

I had the same problem and fixed it in this way: open VLC, preferences, subtitle/OSD, and change default coding to one of Arabic languages.

0

It could be (and looks like) a possible issue regrading encoding. It's probably not UTF-8, and something different.

That being said, if VLC can't play it nothing can. I suggest trying to find different subtitles.

  • I try to download my subtitle from many sites but all Farsi subtitle have the same problem. I can watch this subtitle in vlc in my windows I just have problem in my os x. – Am1rr3zA Sep 1 '10 at 22:48
0

Try with MplayerX which features:

  • Auto detect the encode method of subtitle file (with Universal Charset Detector)
    • Now could support multiple sub files with different encode method
    • Load subtitles while playing - just drag or double-click it
    • Letterbox for the subtitles
  • I turn off MplayerX auto encoding recognition and test as many as encoding that I think was related but still can't see them correct. – Am1rr3zA Sep 20 '10 at 21:11
  • Are you sure that the content is correctly encoded? Try to open the subtitle file with TextWrangler, it should display the charset in the status bar. At this point you can even save in UTF-8 and whatnot. – Carmine Paolino Sep 20 '10 at 21:21

You must log in to answer this question.

protected by Community Sep 7 '17 at 12:38

Thank you for your interest in this question. Because it has attracted low-quality or spam answers that had to be removed, posting an answer now requires 10 reputation on this site (the association bonus does not count).

Would you like to answer one of these unanswered questions instead?

Not the answer you're looking for? Browse other questions tagged .