4

I'm not using Grab, but the screenshot shortcut (i.e., Command (⌘)-Shift-3 and Command (⌘)-Shift-4). A loud snapshot sound plays whenever I screengrab. How can I turn off this sound, and is there any way other than disabling all system sound effects? Perhaps with a Terminal command? I'm looking specifically for 10.8+, if it matters.

Sound

  • 2
    i don't know if you know this, but a quick tap on the mute button before taking the picture will do the trick – Macmaniman Sep 4 '13 at 23:21
4

In short: replace the Grab.aif file with a blank audio file.


  1. Go to /System/Library/Components

  2. Right click on CoreAudio.Component & select Show Package Content

Apple Component Library

  1. Go under Contents/SharedSupport/SystemSounds/system

enter image description here

  1. Make a back up of Grab.aif (duplicate it)

  2. Replace Grab.aif by an empty audio file

Links/Resources

http://forums.macrumors.com/showthread.php?t=797999

3

The easy version: Disable all the sound effects

  1. Click on the Apple logo in the top-left corner of your screen and select “System Preferences…”

enter image description here

  1. Click on the option that says “Sound”

enter image description here

  1. Click on “Sound Effects”

enter image description here

  • This was way easier and worked great. – NateW Jan 15 at 21:29

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .