0

I tried to restore a G5, something went wrong and now I have this at startup:

dyld: library not loaded: /usr/liblibconv.2.dylib
Referenced from /bin/sh
Reason: Incompatible library version: sh requires version 7.0.0 or later, but      libiconv.2.dylibprovides version 5.0.0

Can anyone help please?

I don't have a Tiger cd as I was restoring using Disk Utility. I;ve tried various methods for booting from USB but the G5 doesn't seem to give them any power at boot.

5
  • Where exactly is this error showing? Does a black screen with it show up on boot?
    – sofly
    Sep 4, 2013 at 16:54
  • @SoFly it's at boot. An apple logo displays then immediately after this. It goes no further until the fans go into tornado mode and I power off
    – null
    Sep 4, 2013 at 20:39
  • What disk did you use when you tried to restore it? Or how did you try to restore it?
    – sofly
    Sep 6, 2013 at 1:21
  • I used a dmg and disk utility. I swapped over the DVD drive and have now installed orig osx again. Phew
    – null
    Sep 6, 2013 at 6:54
  • Yeah, sounded like a bad image or install to me, but wanted to verify that you were using the correct media to install the OS on the correct arch.
    – sofly
    Sep 7, 2013 at 13:10

1 Answer 1

1

The resolution to my problem was somewhat messy.

The black screen I mentioned was a result of a failed osx restore. It failed because of a bad dmg. The machine then suffered a kernel panic and I guess it was unable to roll back te changes it had made.

I removed some ugly looking ram and cleaned te others, reinstalled osx from disk using a new drive and have so far not experienced any problems.

Problem caused by dodgy dmg installation and dodgier ram

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .