0

I recently unlocked my iPhone 4S from AU KDDI to one of the carriers here in my country. I can make calls, receive messages but i cannot send messages. I checked the registered number under "Messages-> Send&Receive" and i have my old japanese number still being displayed, and greyed out( meaning i cannot change it). I changed my personal details in my Apple store account but the number has not changed still. Please help me find a solution how i can change this number to display my current number.

1

Go to Settings > General > Phone (or Settings > Phone, depending on iOS version), and see what it says underMy number`. Chances are it still has your old number, if it does, change it to your new one.

Does your old Japanese number have a check mark next to it or is it just greyed out in Messages and FaceTime?

What does it say when you try and send a SMS? What error message are you getting?

Is this only for iMessage or ALL SMS?

Is your Data working?

| improve this answer | |

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .