0

Whenever none of my preferred wifi networks is available and my Airport is turned on a dialog appears that shows all the available networks at the moment. That is as expected.
However, when I exit that dialog as I don't want to connect to a wifi network, it dissappears, the Airport menu icon shows that it's looking for networks again and the dialog appears again. This is annoying.

How can I prevent the dialog from appearing a second time? Turning off the dialog completely would be viable as well as I almost never use it anyway and can have the same functionality through the Airport menu item.

I'm on a MacBook Pro 5,3 (Mid 2009) with Mac OSX 10.8.4.

1

Open System Preferences, go to networks, select Airport and make sure the "Ask to join new networks" check is not selected.

enter image description here

This will suppress the dialog all the time as there isn't an easy way to have it suppress a second dialog in a timeframe or after a disconnect event.

  • This works, thank you. Is there a reason I get to see the dialog twice? I can't recall this was the case several months ago. – Saaru Lindestøkke Sep 3 '13 at 19:38
  • I don't have a good answer other than it's being more eager to get you to join? Do you have two WiFi interfaces in the left side of the pane perhaps? – bmike Sep 3 '13 at 19:40
  • Nope, only Wi-Fi interface. – Saaru Lindestøkke Sep 3 '13 at 20:15

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .