I have a Mac Mini with iTunes 10.2.1 installed, I enabled home sharing in the preferences and the Advanced menu. I also have an iPhone 4 on iOS 4.3, which I enabled home sharing on using the same username and password that my desktop uses.

Both computers are connected to the same home network. When I open up the iPhone's iPod app, however, I don't see any of the songs that are only on the Mac. I only see those that have been synced with the iPhone (i.e. I use this Mac to sync my iPhone).


5 Answers 5


Launch the iPod App on your iPhone. At the bottom of the screen, you should see a More button with 3 blue dots.

As you can see here, there is a Shared list item at the bottom of the page. Click that, which should bring you to a screen like:

enter image description here enter image description here

Click the name of the computer that you see in your list and then all of the videos, movies, tv shows, etc, will appear in your lists for those items.

In other words, the iPod App won't keep the home-shared content separate. You will see the Home Sharing content as if it was integrated with the device.

  • Not sure what caused it to suddenly work, but it works now. Thanks for the screenshots, they should help others in the future.
    – Senseful
    Mar 14, 2011 at 7:08
  • I have yet to get the "Shared" option despite perfect wifi connectivity that syncs just fine. All settings are as specified. Is there any reason this would NOT work?
    – Jé Queue
    Nov 21, 2011 at 17:23

It should be in Music under More -> Shared

Selecting your iTunes library then puts it in a home sharing mode and to return to the iPhone's music go to More -> Shared again

How to use Home Sharing on your iPhone, iPod Touch or iPad

  • I don't see More > Shared on the iPhone's iPod app.
    – Senseful
    Mar 12, 2011 at 17:18
  • 1
    I've added a link which should help
    – Jasper
    Mar 12, 2011 at 23:46

I was having this same issue on my iphone. I just noticed that my phone was connected via my guest wifi network. Switched to my home network and the shared icon came back.


I've had this same situation happen to me. I killed the iTunes app on my iPhone's multitasker, I've restarted my PC, I've disabled and re-entered my credentials repeatedly on the iTunes-PC side as well as the phone side, all to no avail. Home Sharing was there on my phone once before and suddenly it vanished. After hours of turning off firewalls, double checking exceptions in my Windows Firewall and PeerBlock settings, I noticed something. I've noticed my AppleID as "xxxxxx@gmail.com" and just "xxxxxx". Instead of trying the @gmail one I tried using just the ID on my PC and my iPhone, and it magically worked.

  • 1
    I'm a bit confused now, what exactly did you do to resolve the issue? Assuming your AppleID is stevo@gmail.com, what did you enter in iTunes and in the iPhone?
    – nohillside
    Jul 8, 2012 at 18:35

I've been having this issue with my iPhone 4 and I think I just figured out the solution. Go to your iTunes folder on your Mac, and check if there are any files other than the following:

  • iTunes Music Library.xml
  • iTunes Library.itl
  • iTunes Library Genius.itdb
  • iTunes Library Extras.itdb
  • sentinel (hidden)
  • .DS_Store (hidden)

(Any folders are ok, mine has iTunes Media, Mobile Applications, Album Artwork, and Previous iTunes Libraries).

I deleted all other files I found in that folder, restarted iTunes, and voila, the circle now goes all the way, well, full circle.

I only had the following, but you may have more or fewer or the same sort of files to delete:

  • Temp File.tmp
  • Temp File 1.tmp
  • Temp File 2.tmp
  • iTunes Music Library Backup.xml
  • iTunes Music Library Backup 1.xml

I have no idea why this would cause home sharing to stop halfway through loading, but hey, whatever works.

  • deleteing the temp.tmp file as wyatt said in the itunes folder worked isntantly. takes a while to load the library in the first place, but continues past half the little circle loading thing and works.
    – user103098
    Dec 2, 2014 at 14:39

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .