12

Contacts on my iPhone 4 are not syncing to iCloud even though it is set as on. It is a new phone, and the contacts synced when I first set up iCloud, but not since. I have tried "backup now" and new notes appeared, but no new contacts.

3
  • Which iPhone are you using? When you say they're not syncing, are the contacts you want to sync already on iCloud and you're trying to get them onto your iPhone, or are they already on your phone and you're trying to get them onto iCloud? – tubedogg Sep 1 '13 at 19:53
  • It is an iPhone 4, the contacts I've added on the phone are not syncing to iCloud. – Janine Sep 1 '13 at 20:46
  • Go to System Preferences > iCloud, turn off Contacts, wait 15 minutes and turn it back on. Does that help? – tubedogg Sep 1 '13 at 20:49
8

This is what worked for me after speaking with a very helpful Apple senior tech agent:

Open Settings> Mail, Contacts, Calendars> Contacts – Default Account = must contain a check next to iCloud.That’s it! Now all future contacts created on your iPhone (on your iPad, do the same as above), will also appear in iCloud and Outlook (if you’ve also set up Outlook).

If you have contacts that are already only on your iPhone/iPad then you’ll want to: Open Phone> Contacts> Groups (top left corner)> Hide All Contacts (top left corner). Then select/Checkmark all email accounts/accounts you see listed and make sure that iCloud it NOT check marked here while you’re fishing for all those rogue contacts. Click done and what will then be displayed, are contacts that you saved somewhere other than iCloud. Then recreate these contacts you see, one by one, by going into iCloud.com, your other iDevice or Outlook on your desktop and create them as new contacts. For best results I recommend that you DO NOT press save for the new contact until you FIRST press delete* on the non-iCloud contact you are about to make a copy of. Of course press delete only after you’ve copied all of the contact data.

  • To delete a contact on your iPhone/iPad: Contacts> select the contact> tap Edit (top right corner)> Scroll to the bottom and select Delete Contact.
2
  • This is what helped me. Fortunately I had only 5-6 such contacts that needed to be recreated. – Sergio Tulentsev Nov 8 '14 at 13:51
  • This will be a huge pain to re-enter all of these, but this will solve it once and for all. thank you! – CBarr May 14 '16 at 22:43
6

If you have more than one account with contacts, make sure your contacts are saved to your iCoud account and not any other (Settings -> Mail, Contacts, Calendar -> Contacts -> Default Account -> iCloud (or what ever you've named it). I use Gmail as main account, and therefore new contacts aren't added to my iCloud by default.

If you've done that and it still doesn't work, remove your iCloud account from you settings (Settings -> Mail, Contacts, Calendar -> iCloud (or what ever you've named it) -> Delete Account). Restart your phone and add it again and restart it once again. Your contacts, notes, events etc will NOT be deleted from your iCloud account, but any data NOT synced WILL (does not affect other account of course)!


Edit: 2017-01-18 ~ With the advent of all the feature rich apps on your phone, you're likely to find that other apps besides the Contacts configured ones have access to add/modify your contacts, such as Facebook. This is why sometimes you have the same person show up multiple times on your phone, and not on your computer or other devices.

3
  1. Got to Settings
  2. Go to iCloud
  3. Slide Contacts option to Off (You'll get a warning, make sure you choose to save the Contacts on your phone)
  4. Close out of Settings
  5. Wait 5 minutes or so
  6. Go back to Settings / iCloud
  7. Slide Contacts option to On (You'll get a message asking to merge Contacts, say yes)
  8. Go to Settings / iCloud / Storage & Backup
  9. Select Back Up Now
1
  • Simple and perfecet – summerbulb Feb 9 '17 at 16:25
2

I suggest you to try to reset your iCloud Documents.

  • Go to http://www.iCloud.com, sign in with your Apple ID. Click on
  • your name at upper-right corner > account settings Click Reset
  • Documents & Data Confirm reset

    (this will not erase anything, I just did it and it worked fine)

  • Restart your devices

See also : http://support.apple.com/kb/HT5824

0

I have an iPhone 5S and logged into icloud.com (via Windows) and couldn't see my updates from my phone. To resolve this, within icloud.com I selected icloud settings from the top right menu and Advanced > Data Security and select Sign out of all browsers. Once I logged back in online and on my phone the updates appeared. Genuis ;-) !!!

0

I think most of the problem has to do with the fact that contacts can be saved in different groups. If, by default, your iphone doesn't save contacts into your iCloud group it will not sync with Contacts on your Mac. Therefore you need to configure your iPhone to save your new contacts to iCloud rather than another group (like Exchange). Alternatively, you can configure Contacts to also sync with whatever alternative group is on your iPhone.

0

If all of these answers aren't working for you, perhaps the contacts you've been wanting to transfer to your mac aren't in your iCloud account in the first place. https://discussions.apple.com/thread/3515161 this thread fixed my problem, for my contacts were actually stored on the Hotmail-server.

1
  • 1
    Welcome to Ask Different! We're trying to find the best answers and those answers will provide info as to why they're the best. Explain why you think the link you provided will answer the question. Links can change and become outdated so we prefer the answers to stand alone and to not just be a link. See How to Answer on how to provide a quality answer. - From Review – fsb Jan 3 '17 at 17:29
0

It seems the default account under settings->contacts->Default account must be the iCloud account for the new contact to become an "icloud" contact. I cannot find a way to change group for an exisiting contact.

If the default acct as in my case was an exchange account it wont sync to icloud.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .