0

I have had a problem for the past week where a folder action created in Automator has stopped importing photos from a folder into iPhoto.

I have tried: Repairing disk permissions. Deleting the script from library/workflows/applications/folder actions, and then recreating it from Automator once more.

Neither of these worked, and some googling seems to indicate that many people on the Apple support communities have similar problems, so perhaps an update at some point has broken this functionality, and I was unable to fix it.

OSX 10.8.4 iPhoto 9.4.3 (720.91)

1

I decided to scrap the import into iPhoto option, and have no created an alias for the Auto Import folder within the iPhoto package itself, placed this in another folder, and created a new folder action within Automator to: Copy finder items (as I want to leave the original picture in my uploads folder) which points to the alias for Auto Import. Launch application, which opens iPhoto, and therefore imports anything within the Auto Import folder.

This seems to be working reliably after taking several photos on my phone, and rebooting the laptop several times.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .