My house has standard broadband internet. A coaxial cable comes into the house from the road. Attached to this is a wireless router.

My room is right at the other end of the house. I can only get a decent signal by putting a USB Wi-Fi dongle out of one window.

As I have a spare old MacBook, I'm attaching the dongle via a 3m USB extension cable, and putting it out of the window.

I am then configuring this old MacBook to redistribute the Internet, using its internal Wi-Fi card, i.e. the airport.

Other devices can see this new Wi-Fi spot and connect to it. Primarily my new MacBook Air.

But trying on the browser, it fails to load a webpage. 'ping' from the command line fails to resolve www.google.com.

Now here is the weird thing. It has been working on occasion. I don't know if it's the result of my fiddling around.

I've tried quite a few things: I've tried using Bluetooth to redistribute. I've tried setting the IP address for the airport manually. I've tried altering the channel. Probably a few more but I'm not comfortable thrashing around not knowing what I'm doing with no clear gameplan.

Could someone please give me a sequence of moves to tackle this?

  • You know you can only redistribute something that is redistributable :) means you original Connection must allow for multiple IP connections that are needed for other devices to get internet access. So tell us about the USB wifi connection to whom? Check if your wifi provider allows multiple connections.
    – Ruskes
    Sep 1, 2013 at 10:00
  • @Buscar, It is from the home router -- a black box that takes a cable from the road and exposes a wifi network. It works sometimes. That fact should eliminate upstream issues, I think...
    – P i
    Sep 1, 2013 at 16:37
  • I am lost, to Quote you: Out of this window goes a USB Wi-Fi dongle, feeding my old MacBook with juicy fast Internet?? is that where you get your Internet?
    – Ruskes
    Sep 1, 2013 at 17:25
  • @Buscar, my apologies. It was a poorly worded question. I have rewritten it.
    – P i
    Sep 1, 2013 at 20:20
  • 1
    Since we now know you might have more information to help solve this, it would help to please provided it. What is the WiFi profile broadcasting from the old mac. What specific settings do you use in oldMac (Ad hoc.? Internet sharing..). ---FYI--What you trying to set up is called a Repeater. FYI..they cost $50 and will do what you want.
    – Ruskes
    Sep 1, 2013 at 20:45

2 Answers 2


Consider the following tutorial


Admittedly it only covers ethernet to wireless or wireless to ethernet, however the same steps should apply for this setup (wireless to wireless).

Make sure of the following:

  • The incoming wireless has a dhcp lease auto assigned
  • The outgoing wireless on the laptop has a manually assigned ip, the subnet matches the incoming wireless, and that the router field is populated with your dhcp server (router)'s ip.

Here is my configuration (I am using an ethernet to wireless bridge but the principle is the same)

Example incoming wireless enter image description here

Example outgoing wireless

enter image description here

Lastly verify that your old laptop has the correct version of the bootpd service running.

 sudo launchctl list|grep bootp
 26987  -   0x7fc881d5b9e0.anonymous.bootpd


While you will be able to get internet access to any device connected wirelessly to the old laptop, those devices will not be able to communicate with any other devices on the other side of the old laptop.

This is because the old laptop is running a dhcp server and the devices will be in a different subnet.

To prove this, take a look at ifconfig on the old laptop. You should see a new network device called bridge0.

ether ac:de:48:e4:39:77 
inet netmask 0xffffff00 broadcast
    priority 0 hellotime 0 fwddelay 0 maxage 0
    ipfilter disabled flags 0x2
member: en1 flags=3<LEARNING,DISCOVER>
         port 5 priority 0 path cost 0

On my network, all devices that connect to the internet from my 'old laptop' get a dhcp address starting at 192.168.2.x. Those devices can not connect to any device in the 10.4.90.x subnet.

You may be better off buying a wireless repeater, or purchasing a directional antenna for your usb wireless network card.

  • w00t Thankyou! The subnet-masks weren't matching ( vs
    – P i
    Sep 4, 2013 at 20:56

It sounds like you're trying to NAT behind your old Macbook. I assume you're using Internet Sharing (System Preferences -> Sharing) to do so, which will auto-configure a NAT for you.

If you are able to connect to the Macbook's shared connection at all you should check the routing table of the machine you are connecting to the Macbook NAT from. You might have a duplicate route, or traffic might be going the wrong way.

You can do this via Network Utility (GUI for netstat). In Network Utility on your client machine go to the Netstat tab, click the radio button "Display routing table information", and then press "Netstat".

If you run an ifconfig on your Macbook, the IP of a secondary interface (br0, tun0, etc OR your internal card - NOT your wifi dongle) should be a local IP - i.e. 192.168.x.x or 10.0.x.x. Ensure that the default gateway in your client machine's routing table is the same as the IP of the network interface that corresponds to your shared connection.

You can change the default gateway via the "Network" System Preferences pane, or using the route command, i.e.

route delete default
route add default <Macbook ip>

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .