1

Problem:

I cannot boot into system nor can I boot to the installation disk.


Errors I get in verbose mode:

BSD root: disk0s2, major 14, minor 2
disk0s2: media is not present
0 [Level 3] [ReadUID 0] [Facility com.apple.system.fs] [errType IO] [ErrNO 6] [IOType Read] [PBlidNum 2] [LBder First]
0 [Level 3] [ReadUID 0] [Facility com.apple.system.fs] [FSLogMsgID 1188483988] [FSLogOrder Last]
hfs_mountroot failed: 6
cannot mount root, errno = 19

What happened:

It all started with a slow laptop, Safari couldn't be killed, the only working browser was Chrome. Than it the Mac started to freeze from time to time and I had to kill it. I checked the Harddrive for errors but Diskutility didn't show anything. Next it wasn't able to boot anymore. First I fixed that by booting into Save Mode (hold Shift after Power Up bling) and it worked as before (slow) but started freezing up again very soon. I tried to fix that by using the Snow Leopard Installation Disk and repaired disk and permissions with Diskutility. It worked for an hour or so and then froze again. I killed it with the Power Button and after that I couldn't boot from hard drive nor from the disk! I tried the one that came with the laptop, but that one didn't boot either.


Working switches in boot mode are:

  • CMD+V, Verbose
  • Option key, to choose drive (it shows both the hard drive and the disk),
  • Shift+CTRL+Option+Power, Reset SMC (not sure if that worked),
  • CMD+Option+P+R, Reset NVRAM (pretty sure that worked)

Non of the others have any effect other than that the time until the spinning ball stopps spinning will be longer than a usual boot.


Questions:

What to do? Is there a way to get a verbose boot mode for installation disk as well? Help!


Hardware:

mid-2009-macbook-pro unibody with 160 GB harddrive, OSX Snow Leopard 10.6.4 (not sure)

1

It could be a hardware problem or a media problem. You might have a defective DVD drive in your MacBook Pro, or your installation DVD could be scratched or corrupted. You might need to take the unit to a qualified technician who could try the installation with a known-good 10.6.x installer DVD to isolate the problem.

Also, is the installer DVD for 10.6.4 the same one that shipped with the computer? If it is a replacement that you got from elsewhere, it may not be the right version number to work with the firmware and version of your particular model of Mac. I have seen that problem arise before. Some Snow Leopard installer DVDs were 10.6.0, and some later ones were 10.6.4, and certain models of Mac would not accept an installer DVD that was 10.6.0 and not 10.6.4.

  • Thank you. As I stated, it worked before with that installation disk but of course it might have been damaged in between, but I doubt that. Actually the first time I used a disk that didn't ship with the computer and later when i couldn't boot it anymore, I tried the one that came with the laptop. PLUS eventhough the drive could be damaged, that wouldn't explain, why the system is not bootable either, right? – sir_brickalot Aug 30 '13 at 12:03
  • Correct. You could have both a failed DVD drive and a corrupted software installation that won't boot, and/or a defective DVD installer disk. It would not be out of the question to have more than one thing goinging wrong. You need to troubleshoot further. – user9290 Aug 30 '13 at 15:56
  • OK I had the chance to try a different HDD and with that I could easily run the installation disk. Crystaldiskinfo on Windows said that SMART had a few pending sectors. So they have to be in the boot sector or something like that. Really nasty. – sir_brickalot Sep 2 '13 at 15:42
0

Solution:

Harddrive failed. I checked the harddrive with Crystaldiskinfo on Windows and SMART said there were pending sectors. I bought a new harddrive (SSD this time) and have to reinstall the system. But I was still able to make a backup of my data from the old drive.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .