3

I purchased OS X 10.7 lion about two years ago, and installed it on my Mac running 10.6.8.

A couple of hours ago I re-formatted my computer and re-installed Mac OS X 10.6.8 Snow Leopard from the original DVD installer. Now I want to go to the App Store and re-download the OS X Lion installer, to upgrade my system to Lion.

The problem is that when I go to App Store and try to download the OS X 10.7 Lion installer, it reloads the same page and nothing happens.

Screen shot

I tried to delete the App store cache and re-install, but it did not work.

Any help?

Thanks

  • When you re-installed OS X 10.6, are you sure that you ran Software Update and installed all of Apple's updates and patches to 10.6.x, before you tried to download the OS X Lion installer? Check again. – user9290 Aug 29 '13 at 17:30
  • Same problem here. When you click "OS X Lion", you get a message: "Item Not Available", "The item you've requested is not currently available in the UK store" – Greg Woods Oct 18 '13 at 0:13
  • How thorough was your re-formatting? Did you wipe out the recovery partition as well? – Jari Keinänen Nov 3 '13 at 11:10
1

When a new OS X is released, it isn't no longer possible to download the previous version(s).

Apple has however now with the release of OS X Mavericks (10.9) again opened up for re-download of Lion and Mountain Lion (if previously purchased) - or to purchase the two OS's for a price of $19.99 each.

OS X Lion (10.7)

OS X Mountain Lion (10.8)

0

Try signing out of the App Store, restarting your Mac, then signing back into the Store. I've seen this happen with other purchases.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .