0

Whenever my Mac goes to sleep when its on battery, it straight away saves its contents to the hard drive and powers off, going into a deep sleep.

This gets really annoying when I walk away for 10 minutes to make a coffee for example and come back to have to wait up to a minute (depending on what I'm running) for the laptop to wake up. This only happens when its on battery though.

I have tried an SMC and cleared the PRAM/NVRAM but it hasn't seemed to work.

Admittedly the other day I was using a terminal command to disable hibernation when plugged into a power supply and must have mucked it up then. I don't seem to remember the command that I used and therefore can't use it to reverse it.

But yeah would there be a way to stop my laptop from hibernating the second it goes to sleep on battery power?

  • type history | grep pmset or just history into your shell to find the full command you ran. Update your post with it. – njboot Jun 12 '14 at 5:17
1

The default hibernatemode on Apple laptops is 3 which does the following:

hibernatemode = 3 (binary 0011) by default on supported portables. The system will store a copy of memory to persistent storage (the disk), and will power memory during sleep. The system will wake from memory, unless a power loss forces it to restore from disk image.

So, to have instant wake from sleep change the hibernatemode to 0 which does the following:

hibernatemode = 0 (binary 0000) by default on supported desktops. The system will not back memory up to persistent storage. The system must wake from the contents of memory; the system will lose context on power loss. This is, historically, plain old sleep.

To see what your current hibernatemode is set to, run the following command:

pmset -g | grep hibernatemode

To change the hibernatemode for instant wake from sleep, run the following command:

pmset hibernatemode 0

0

Possibly you tried this already, but going into system preferences and making sure the hibernation time is a useful number like 30 minutes? And restarting to make sure it's "set".

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .