4

Once per second I'm getting the following errors in my system.log:

Aug 28 01:15:00 Air com.apple.launchd.peruser.501[122] (com.apple.notificationcenterui.agent[52635]): Exited with code: 1
Aug 28 01:15:00 Air com.apple.launchd.peruser.501[122] (com.apple.notificationcenterui.agent): Throttling respawn: Will start in 1 seconds
Aug 28 01:15:01 Air.local NotificationCenter[52636]: Unable to load nib file: MainMenu, exiting

Is this likely affecting system performance, and what can I do about it?

Note that the "Air" in the log is my very creative name for the MacBook Air computer I use. Also, Notification Center is delivering notifications as expected through all this; I don't know why it's attempting to respawn because as far as I can tell, the process isn't dead.

The output of ps -x |grep otific is

 341 ??         0:22.61 /System/Library/CoreServices/Notification Center.app/Contents/MacOS/NotificationCenter -psn_0_430185

Notifications appear as expected.

The file /System/Library/CoreServices/Notification Center.app/Contents/Resources/en.lproj/MainMenu.nib has the following ls -l entry:

-rw-r--r-- 1 root wheel 1787 Jul 25 2012 MainMenu.nib

  • 2
    I made it stop by disabling Notification Center (launchctl remove com.apple.notificationcenterui.agent), but that's rather the very definition of throwing the baby out with the bath water. – Daniel Aug 28 '13 at 5:39
  • 2
    @DanielLawson I think the file it is trying to open is /System/Library/CoreServices/NotificationCenter.app/Contents/Resources/en.lproj/MainMenu.nib. Any problems you can see with that file? On my system it's a binary property list, owned by root/wheel, permissions -rw-r--r--. – zigg Sep 2 '13 at 16:32
  • Does the problem go away if you boot in Safe Mode? – sayzlim Sep 2 '13 at 18:04
  • Did you find out who it is ? sudo find /Applications -user 501 | less – Ruskes Sep 2 '13 at 19:00
  • 1
    @Buscar웃 What do you mean "who it is"? I know it's Notification Center, and I'm the only user running on the machine. – Daniel Sep 2 '13 at 19:32
1

The solution is a bit of a mystery but if you really have /System/Library/CoreServices/Notification Center.app with the space and not /System/Library/CoreServices/NotificationCenter.app you may have to reinstall the OS or restore that entire directory from backup (or another similar Mac OS install).

As to the load on the computer due to the logging - it should be harmless or at worst a minor slowdown. I have Macs with thousands of messages a minute and can barely measure their load running Activity Monitor even when I have several windows up tailing the logs, grepping for patterns to filter out noise like you mention.

You can assure yourself the system is not loaded with the following command:

 iostat 15

You can run with the notifications running and the error messages and without and watch for long term problems in terms of CPU usage and disk IO. Airs and other SSD based Macs generally have plenty of horsepower to deal with thousands of messages a second let alone per minute and the system logging infrastructure scales very well, uses little RAM and is miserly with CPU and disk access.


Now, as far as hunting down the culprit - it's going to be a bit of sleuthing unless someone has already slayed this bug by noticing why the space got added in that directory for the app.

I would probably edit the plist file for that process to set the respawn to be 100 or 300 or 600 until you have a handle on the error (and if you don't want to see so many messages). Also, when you have unloaded (or removed) the job from launchd control, you could manually run the program from the terminal to see if it output any errors on startup that might help you.

 launchctl unload /System/Library/LaunchAgents/com.apple.notificationcenterui.plist   
 /System/Library/CoreServices/NotificationCenter.app/Contents/MacOS/NotificationCenter

You can quit the app by pressing control+c - If it's a permission error, you could test that by running the process as root:

sudo /System/Library/CoreServices/NotificationCenter.app/Contents/MacOS/NotificationCenter
  • Now we're getting somewhere: it's not a permission error; it crashes with 2013-09-02 21:17:25.056 NotificationCenter[84032:707] Unable to load nib file: MainMenu, exiting even with sudo – Daniel Sep 3 '13 at 1:18
  • maybe the file is corrupt somehow. But the hash is the same as yours. – Daniel Sep 3 '13 at 1:19
  • Well - perhaps the app is the problem and not the nib file. Again, I'd be sure I had a good backup and perhaps boot to recovery tonight and let disk utility try to repair things once you're sure you have a safe backup complete. – bmike Sep 3 '13 at 1:49
  • Yeah. I'm going to be rendering for the next 24 hours straight, so nothing gets changed on my system until my first week video lectures are posted. – Daniel Sep 3 '13 at 2:34
2
+200

This might be nothing but twice you referred to the file as

"/System/Library/CoreServices/Notification Center.app"

(note the space)

but I find the app at

"/System/Library/CoreServices/NotificationCenter.app"

on my Mountain Lion systems.

Does the path in /System/Library/LaunchAgents/com.apple.notificationcenterui.plist have the space?

If your system does have a space in that path, it could be causing problems.

I would log out and then either login via ssh or >console at the login window, remove the space:

sudo mv -vn "/System/Library/CoreServices/Notification Center.app" "/System/Library/CoreServices/NotificationCenter.app" 

and then reboot

sudo shutdown -r now
  • It looks like you're onto something! I have both NotificationCenter.app and Notification\ Center.app, with different dates. – Daniel Sep 3 '13 at 4:35
  • apple.stackexchange.com/questions/100810/… shows that the space is supposed to just be the localized name - not actually where the app is stored on the filesystem. It looks like Daniel could either move it back like you described or delete both and reinstall the OS / restore that app from Time Machine backups. – bmike Sep 3 '13 at 18:20
  • I'm pretty sure that I messed it up by fiddling with it before I had Time Machine running. Looks like reinstalling somehow is the way to go. – Daniel Sep 3 '13 at 20:03
  • You identified the likely source of my problem, but when I tried this, now Notification Center doesn't run at all and I still get the error messages. So yes, this is related to the problem, but the solution actually made things worse, unfortunately. – Daniel Sep 4 '13 at 5:48
  • As Apple used to say of the SyncServices directory: "As if it were a swarm of bees, you should stay away from the SyncServices folder.' Same goes for /System/. Even more so than SyncServices. It's time to backup your important files and reinstall. And then remember not to muck around with anything in /System/ in the future. – TJ Luoma Sep 5 '13 at 15:55
0

One possible solution would be to tolerate the problem for the next few weeks, then install OS X 10.9 Mavericks once it is released.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .