6

I have had my MacBook Pro for a couple of months (recent Windows convert and total Mac novice). I am running OS X 10.8.4.

Our cable company recently upgraded our modem and cable box and I am no longer able to connect to the Internet over Wi-Fi.

I can connect via Ethernet. Also, two windows laptops, two iPhones and an iPad are all connected via Wi-Fi so I believe the wireless signal is working and can be connected to.

I can see the network but when I enter the password the login box shakes like an incorrect password was entered. This is the same password I use for the other devices and I have carefully entered it many times so it should work.

I would appreciate any thoughts you might have.

Thanks, Jason

  • I just used the assist on the network pane to sort the issue – user143542 Aug 29 '15 at 12:46
3

I would recommend removing the wireless network from your preferred networks. You can do this by going to your network preferences. As follows:

Open Network Preferences > Select your Wi-Fi connection > Advanced.

enter image description here

Select the network from the list on the first Wi-Fi Tab and hit the [-] key then click OK.

enter image description here

Once you have done this, click Apply on the next screen.

Next you want to remove the password from your keychain to make sure its gone. So open up Keychain Access Application.

Search for the wireless network name. Select the network name and hit delete key. Click the delete prompt to be sure.

enter image description here

Close Keychain access and retry connecting to the wireless. This should have removed all traces of the wireless network from your computer and allow you to try it again.

  • Just a note that several times now, people have been subsequently able to connect to my WPA-secure wireless network after I opened the Guest Network, no password. Hell if I know why, but it worked. – Zo219 Aug 28 '13 at 7:57
  • @Lyken, thank you for the detailed answer. When I went to complete those steps I found that my network was not saved in my preferred networks. Not knowing what else to try, I accessed my routers configuration settings and examined my options there. I attempted to change the security to WEP but was unsuccessful (not sure why). However, upon exiting the configuration I was then able to connect via Wi-Fi. Unfortunately, I am not smart enough to deduce why it now works so I can't add much to the conversation. Thanks again for your help. – Jason Aug 28 '13 at 10:48
  • Cool. You can always use that keychain hint for other password issues later down the track. Can you put in a new answer that outlines what you did from your comment and mark it as answered please? – Digitalchild Aug 28 '13 at 21:07
0

I had the same problem. I kept entering the WPA2 password CORRECTLY, and it was rejected each time.

I went into Settings as above to change, and noticed that everything was grayed out. I then remembered that the account I'm usually logged into is not an administrator's account (for security reasons).

So I had to go back to the main Network pref pane, click the lock icon, and give my administrator login name and password.

Without doing anything else, I was now able to access the wifi network again and it took my password without any difficulty

0

I'm not sure if this will work with you, but my brother has the same issue. He uses a MacBook Pro 2010, while I have a MacBook Pro 2011. I can connect to my Wifi, yet he can't. Invalid password always comes up.

After trying some ways, I found that I need to turn ON QoS setting on my Wi-Fi. And set it to WMM (Wi-Fi Multimedia) (if not available, I think just turn it ON). This setting is located on your Wi-Fi-router admin page, network tab, wireless section (Wi-Fi admin page usually just type on your browser 192.168.1.1 from connected device, with "admin" username and password).

Now both of us can connect.

0

I had to remove a custom "location" in network preferences. Once i did that, using "automatic" instead, everything started working again.

0

.Hi Guys. I obviously was having the same trouble. What I did by chance was have my Macbook Pro El Capitan connected to my router with a serial cable and accessing the net and just removed the cable, and hey-ho it's working!

0

I had the same issue with my 2006 MacBook 1181a after I upgraded the router in my apartment and installed an extender. I tried everything to no avail. Then I went into to admin page of my network and changed my password and it is working just fine now! Hopefully it will stay that way. I had only numbers as my passcode before, now i have numbers and letters. Maybe that had something to do with it? Good luck and I hope this helps!!

0

Just fixed this problem for myself. One computer would not connect, even with the correct password. It would connect to a MiFi card, however. And every other device could connect to the router. So, they were both working, but not with each other.

Both the computer and router support 2.4 GHz and 5 GHz. But it turns out the 5 GHz transmitter on the computer failed, but was still trying to connect at 5 GHz. My router was configured to use the same SSID and password for both configurations, so I changed the 5 GHz to use a different SSID. That forced the computer to connect at 2.4 GHz and everything started working again.

You must log in to answer this question.

protected by Community May 5 '18 at 6:49

Thank you for your interest in this question. Because it has attracted low-quality or spam answers that had to be removed, posting an answer now requires 10 reputation on this site (the association bonus does not count).

Would you like to answer one of these unanswered questions instead?

Not the answer you're looking for? Browse other questions tagged .