2

I am trying to mount a TrueCrypt file on my Mac (OS X 10.8).

When I do so I get the following error:

hdiutil: attach failed - no mountable file system

That is all there is. I tried running from the command line, but it switches to the GUI and then gives the same error.

  • The password is correct. It gives a different error, if I mistype it.
  • The file is mountable and readable on Linux (Kubuntu 12.08 and 13.04)
  • I have two files were this happens (one is 470 Gb, the other is 300 Gb). One file where this is not the problem and at least reading works fine (haven't tested writing). That file is only 90 Gb.
  • The external disk where these files are on is formatted as ext4, which I mount through ext4fuse.

Please help me, I am in the process of copying the data onto a Mac compatible external disk. At the moment I am rsyncing over Wifi and it requires two computers running and takes ages.

UPDATE

  1. Yesterday night, I copied the 300 Gb file to my Mac formatted external disk. The same problem happened, thus I'd conclude that it is not an ext4fuse issue.

  2. The TrueCrypt volume is internally formatted as ext4.

  3. It does not contain a hidden volume.
  • I get the same mounting error. I tried what Toby did and I was able to mount the volume from a terminal window. However, when I go into DiskUtility, it shows a "volume.dmg" that is mounted. I cannot access anything on it. If I try and mount it, it says "No Mountable file systems" I have gigs of data on this drive, and I really need it back. – Brian Allison Jun 4 '15 at 15:15
  • I got this when I was mounting to a directory that didn't exist. Bad error message, but easy to fix. – Dan Jameson Apr 14 '16 at 19:57
1

Try mounting the volume as “read-only”:

TrueCrypt → Preferences → Mount Options → Mount Volumes as read-only

Truecrypt Preferences

If that doesn't do the trick then it's possible TrueCrypt could be having some issue with file system implementation mechanism (ext4fuse) not detecting that an ext4 volume is mounted. I've used FUSE for OS X with TrueCrypt and it works without any issues, so giving that a try instead of your current mechanism might help as well.

  • Yesterday night, I copied the 300 Gb file to my Mac formated external disk. The same problem happened, thus I'd conclude that it is not an ext4fuse issue. Am I right? – Unapiedra Aug 29 '13 at 10:39
  • I also tried using the Mount Read-only option, however made when entering the password (click Options). Not in the general settings. – Unapiedra Aug 29 '13 at 10:41
  • It may be the problem is with Truecrypt and ext4fuse, not so much OSX and ext4fuse. – l'L'l Aug 29 '13 at 10:42
  • Could it be that the truecrypt volume is internally formatted with ext4? – Unapiedra Aug 29 '13 at 10:42
  • It could be; you would likely have to check via your Linux system that is able to mount it. Does the Truecrypt volume contain a hidden volume as well? – l'L'l Aug 29 '13 at 10:43
1

Try selecting "Do not mount" in VeryCrypt and then mount the disk manually. Open terminal:

diskutil list
/dev/disk5 (disk image):
   #:                       TYPE NAME                    SIZE       IDENTIFIER
   0:                            VERACRYPT               +10.2 MB    disk5

diskutil mount /dev/disk5
Volume VERACRYPT on /dev/disk5 mounted

There seems to be a problem with FAT32 and exFAT filesystems. After manually mounting the volume, I created a new with HFS+. I was able to mount it without any problems. I'm using Mac OSX High Sierra.

0

In the end, I did not find a way to make this work under OS X. I copied the file to a Linux machine, mounted it and then scp'd everything to my OS X running machine. Reasonably simple but takes some time and one needs access to two machines.

0

I have been using a truecrypt container to hold the contents of my homedir and mounting it at every boot from a login hook. It worked like a charm, but due to the recent truecrypt oddities, I decided to switch to filevault. After the switch, I wanted to mount my truecrypt container (which contains a HFS+ filesystem) to copy over my data, and received the above error.

After the initial break of sweat as I feared I lost all my data including a large part of my backups, I was able to resolve this by

  1. Mounting with truecrypt and the options --filesystem=NONE and (for safety) -m ro
  2. With OSX Disk Utility, I was able to then simply mount the volume and copy over my stuff
0

Please make sure the filesystem where the TrueCrypt volume is placed is not mounted read-only...

Somehow I figured out that on MacOS you need a read-write filesystem even if you are only trying to mount it as read-only.

-2

The file you're trying to mount may have been made on a "none" file system.

  • 2
    Could you elaborate on what a "none file system" means? – bmike Aug 21 '14 at 15:14

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .