2

“Cannot sign in because the server version is incompatible with Microsoft Lync. Contact your support team with this information.”

I am trying to use the Lynx for Mac 2011 (v14.0.5) instead of Communicator after our corporate Lynx servers was already upgraded.

The Windows users are able to use Lynx, if they do follow DisableServerCheck trick for Lynx.

Obviously, this doesn't work on Mac as there is no registry.

Any suggestions?

4

See this link.

Basically, you have to edit the plist for Lync, and enter a registry key equivalent.

The explanation is below:

Basically, the equivalent to the registry keys for windows needs to be entered in the Lync config plist file on the mac, a file named MicrosoftLyncRegistrationDB.xxx.plist that you can find in ~/Library/Preferences/ByHost.

In it, you will need to create an entry for each segment of the reg key path for the DisableServerCheck flag (all lower case). It should look like this:

hkey_current_user\

hkey_current_user\software\

hkey_current_user\software\policies\

hkey_current_user\software\policies\microsoft\

hkey_current_user\software\policies\microsoft\communicator\

hkey_current_user\software\policies\microsoft\communicator\disableservercheck

The value for each of the path segments is "<>" and type string. For the disableservercheck flag, the type is "Number" and the value is 1.

You can use a plist editor (there's a few free ones for the mac, or you can also use Xcode) to edit the plist file. The screenshot below shows you how it should look like.

  • 1
    Thank you Dave, I managed to tune the plist file and convince Lync to start but it worked for less than 10 seconds. Now it doesn't work again, saying something about login credentials, the same credentials that worked once. – sorin Aug 27 '13 at 15:28

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .