I have two similar iMacs (27" - i7 - os10.8.4 ) and use Apple's extended USB keyboards on both of them. After a power outage neither keyboard will work on one iMac (A) although both keyboards work fine on the other iMac (B). I have reset NVRAM and SMC on iMac A but to no avail. I have plugged printers into the USB ports and they seem to work fine. As it stands, the only way I can log in on iMac A is by using a Bluetooth keyboard, the USB port however remains "invisible"...

Thank you for your help.

  • I presume your question is how can you reconnect the keyboards to the USB port on iMac A?
    – Dave
    Aug 26, 2013 at 21:43
  • Yes Dave, that is my issue. Plugged my keyboard(s) into the iMac (A) and it's as if I plugged "nothing" into the USB port, i.e.: the mac does not see it (even checking the USB port status using "About This Mac"/system info)... Strange, as anything else plugged into the same ports does appear, as it should. Aug 29, 2013 at 21:09
  • I have the same problem. iMac 27" i5 OS X 10.8.4 Sep 2, 2013 at 15:44
  • 3
    Do other USB ports work?
    – Kevin Chen
    Sep 4, 2013 at 2:24
  • What if you connect a powered USB hub to the computer, and the keyboard to the hub?
    – Kent
    Sep 5, 2013 at 1:12

3 Answers 3


Sorry this isn't really an answer but I can't post a photo in a comment.

I have a 27" iMac i7 as well, when I connect a Key Board/Mouse and an iPhone via USB in "System Information" I see this:

enter image description here

What do you see?

Note that the two USB ports are on different busses. Have you tried both of them? You mentioned that bluetooth works; do the other USB functions work (Card Reader, iSight Cam)?


I just got a new iMac with OS 10.8.4 (Snow Leopard) I opted for a USB keyboard and the keyboard stopped working twice now upon restarts.

BUT when I plugged in my old Mac keyboard (which is clunky and encased in a clear plastic like tray) it works fine. My new sleek USB keyboard doesn't.

I feel that all of these problems may be the newer keyboards. The USB plugs even seems wimpier.


This isa recurring problem for me and whilst I once solved it from a site like this, this time I just plugged the damn thing into my macbook air and back to the Imac. Bingo!


You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .