This answer was last tested 5/20/20023 using macOS Ventura on a 2018 Intel Mac mini. The USB flash drive was successfully used to do a clean install of OS X El Capitan on a 2007 iMac.
Note: On 1/31/2021, M. Justin reported this answer works for Yosemite.
Further testing has found this answer works for Sierra. In the case of Yosemite and Sierra, you will need to make the appropriate substitutions in the instructions given below. If you want a version where the substitutions have already been made, the see here for Yosemite and here for Sierra.
I have posted two alternative answers to this question.
The first alternative answer involves using a virtual machine. This answer is must less of a complex, because Apple explicitly inserted code into the El Capitan installer to bypass the checking of the model when executed in a "VMware Fusion Player" virtual machine. So, Apple evidently intends for users of newer model Intel Macs to use this new answer to retrieve the Install OS X El Capitan
application. Still, I would like know from Apple why they thought such a complex procedure is necessary.
The second alternative answer involves using an older Mac capable of running Snow Leopard (OS X 10.6).
Below is my original answer.
Note: This answer was adapted from Klanomath's answer to a slightly different question.
Note: A version of this answer, which uses a Windows to create the USB flash drive OS X El Capitan installer, can be found here.
There is a link on the Apple website "How to download macOS" that will download a file that can be used to create the Install OS X El Capitan
application. However, if the model Mac is too new to allow the installation for El Capitan, then message given below will occur when trying to create the Install OS X El Capitan
application.
This version of OS X 10.11 cannot be installed on this computer.
If you are trying to create a USB installation flash drive of use on another Mac computer, then you can still use the downloaded file to create this installer. The instructions are given below.
This method was verified by using the following configurations.
- Catalina on a MacBook Pro 2017 touchbar for use on iMac 2009 24”.
- Mojave on a Mac mini 2018 for use in a VirtualBox virtual machine on a iMac 2013 21.5".
- Catalina on a iMac 2013 21.5" for use in a VirtualBox virtual machine on the same Mac.
Create Bootable Installer Directly from Downloaded File
The following steps can be used to create a USB installer for El Capitan.
If you have not already downloaded then InstallMacOSX.dmg
file for El Capitan, then use instructions on the Apple website "How to download macOS" to download this file.
Use the Disk Utility to erase a 16 GB or larger flash drive. If the Disk Utility window has a View
pulldown menu, make sure Show All Devices
is selected. Highlight the flash drive, then click on the Erase
button. Use the setting shown in the image below.
Next, click on the Erase
button. When finished erasing, click on the Done
button.
Use the Finder applicaition to open InstallMacOSX.dmg
.
Enter the commands given below. A folder named El Capitan
will be created in the /tmp
folder to hold temporary files.
Note: The easiest way to enter the commands is to copy from this document and paste in the Terminal window.
rm -rf /tmp/El\ Capitan
pkgutil --expand /Volumes/Install\ OS\ X/InstallMacOSX.pkg /tmp/El\ Capitan
diskutil eject Install\ OS\ X
cd /tmp/El\ Capitan
hdiutil attach InstallMacOSX.pkg/InstallESD.dmg -noverify -nobrowse -mountpoint /Volumes/esd
sudo asr restore -source /Volumes/esd/BaseSystem.dmg -target /Volumes/MyVolume -noprompt -noverify -erase
After entering the last command given above, you may get a message similar to the one given below.
asr: Couldn't personalize volume /Volumes/OS X Base System
Some versions of macOS will produce this message while other versions do not. I suspect this is an fatal message because an exit status of 1 was returned.
Inspection has determined that the part of the command that failed is unimportant.
Therefore, I was able to ignore this error. However, the error can also be avoided by applying the following steps given in the section below titled Alternative to Using the asr
Command.
To finish creating the bootable USB flash drive El Capitan installer, enter the commands given below.
diskutil rename OS\ X\ Base\ System Install\ El\ Capitan
rm /Volumes/Install\ El\ Capitan/System/Installation/Packages
cp -rp /Volumes/esd/Packages /Volumes/Install\ El\ Capitan/System/Installation
cp -rp /Volumes/esd/BaseSystem.chunklist /Volumes/Install\ El\ Capitan/
cp -rp /Volumes/esd/BaseSystem.dmg /Volumes/Install\ El\ Capitan/
hdiutil detach /Volumes/esd
sudo bless --folder /Volumes/Install\ El\ Capitan/System/Library/CoreServices --label Install\ El\ Capitan
cp /Volumes/Install\ El\ Capitan/Install\ OS\ X\ El\ Capitan.app/Contents/Resources/InstallAssistant.icns /Volumes/Install\ El\ Capitan/.VolumeIcon.icns
cd "$HOME"
rm -r /tmp/El\ Capitan
diskutil eject Install\ El\ Capitan
Remove the flash drive. You are done.
Alternative to Using the asr
Command
The command given below may generate a error message and/or hang depending on the version of macOS and perhaps the model Mac you are using.
sudo asr restore -source /Volumes/esd/BaseSystem.dmg -target /Volumes/MyVolume -noprompt -noverify -erase
You can avoid entering the above command by following the steps given below.
If the volume on the USB flash drive is no longer labeled MyVolume
, then use the Disk Utility to erase the flash drive. Highlight the flash drive, then click on the Erase
button. Use the setting shown in the image below.
Next, click on the Erase
button. When finished erasing, click on the Done
button.
Enter the following command to create a sparse flash drive image.
hdiutil create -type SPARSE -size 10g -layout MBRSPUD -fs HFS+J -volname MyImage -attach /tmp/El\ Capitan/MyImage
Basically, you want to restore to volume MyImage
from the hidden file BaseSystem.dmg
. The hidden file BaseSystem.dmg
is shown in the Finder window image shown below. The drive OS X Install ESD
can be found in the hidden volume Volumes
in the root folder.
There are various ways to view hidden files. These ways depend on the version of OS X or macOS you are using. You may have to search the web for a way that works for you.
Highlight the MyImage
volume shown in the Disk Utility main window. Click on the Restore
button, then the Image
button. Select the BaseSystem.dmg
file, as shown below. Next, click on the Restore
button.
After a successful restore, you should see the image shown below. You can click on the Done
button and quit the Disk Utility.
Also, you should get the following popup.
Enter the following commands to clone to the flash drive.
Note: The dd
command takes a long time to complete. See this answer to track the progress of the dd
command. The bytes to be transferred is approximately 10 GB.
getdsk() { local "x=$(diskutil info "$2" | grep Part\ of\ Whole)"; eval $1'="/dev/r${x##* }"'; }
getdsk DSK1 OS\ X\ Base\ System
getdsk DSK2 MyVolume
diskutil unmountdisk $DSK1
diskutil unmountdisk $DSK2
sudo dd if=$DSK1 of=$DSK2 bs=1m
diskutil eject $DSK1
diskutil unmountdisk $DSK2
diskutil mountdisk $DSK2
Note: Since the original will be immediately ejected and eventually deleted, I did not bother to use the hfs.util
command to change the UUID of the clone.
You can now proceed with the rest of the steps.
References
How do I make a bootable USB flash drive on a Mac?
What is the best way to generate a Yosemite or Mavericks Install USB flash drive?
Install El Capitan with VirtualBox on OS X
createinstallmedia
that will make the USB for you.dmg
file. You have to mount it so you can see the contents. Try this in Terminalhdiutil attach /path/to/dmg