2 Clarified a couple of things, and improved caps.
source | link

After syncing you may come across calendars not displaying (for whatever reason), despite them showing up on your calendar list in your calendar app. To remedy this, go into your phoneopen settingsSettings.app >-> mailMail, contactContacts, calendars& Calendars > -> select your account[your account].

  1. turnTurn off calendars
  2. turnTurn on calendars

All your calendars should now show up in the app.

After syncing you may come across calendars not displaying (for whatever reason), despite them showing up on your calendar list in your calendar app. To remedy this, go into your phone settings > mail, contact, calendars > select your account

  1. turn off calendars
  2. turn on calendars

All your calendars should now show up in the app.

After syncing you may come across calendars not displaying (for whatever reason), despite them showing up on your calendar list in your calendar app. To remedy this, open Settings.app -> Mail, Contacts, & Calendars -> [your account].

  1. Turn off calendars
  2. Turn on calendars

All your calendars should now show up in the app.

1
source | link

After syncing you may come across calendars not displaying (for whatever reason), despite them showing up on your calendar list in your calendar app. To remedy this, go into your phone settings > mail, contact, calendars > select your account

  1. turn off calendars
  2. turn on calendars

All your calendars should now show up in the app.