We’re rewarding the question askers & reputations are being recalculated! Read more.
2 detailed fix for keyboard issues i encountered while using XQuartz with No Machine
source | link

I installed the XQuartz application. It was in /Application/Utilities/XQuartz.app. I just renamed it from XQuartz.app to X11.app and everything works fine, so far.

Update: don't install XQuartz for use with No Machine. I opened a text editor and started typing, all the keys were screwy. For instance, the Delete key was now comma, all the letters were transposed, general chaos. I replaced XQuartz with the official X11User.dmg package and this keyboard problem went away. One more step I had to take: when on the remote desktop I tried to cd into a different directory, and hitting the "d" key kept showing me the desktop. If you want to cd, you will need to go into System->Preferences->Keyboard shortcuts. Scroll down, and notice an entry "Hide all windows and show desktop" which is mapped to "D". Change this to Alt+D or Ctrl+D and cd away!

I installed the XQuartz application. It was in /Application/Utilities/XQuartz.app. I just renamed it from XQuartz.app to X11.app and everything works fine, so far.

I installed the XQuartz application. It was in /Application/Utilities/XQuartz.app. I just renamed it from XQuartz.app to X11.app and everything works fine, so far.

Update: don't install XQuartz for use with No Machine. I opened a text editor and started typing, all the keys were screwy. For instance, the Delete key was now comma, all the letters were transposed, general chaos. I replaced XQuartz with the official X11User.dmg package and this keyboard problem went away. One more step I had to take: when on the remote desktop I tried to cd into a different directory, and hitting the "d" key kept showing me the desktop. If you want to cd, you will need to go into System->Preferences->Keyboard shortcuts. Scroll down, and notice an entry "Hide all windows and show desktop" which is mapped to "D". Change this to Alt+D or Ctrl+D and cd away!

1
source | link

I installed the XQuartz application. It was in /Application/Utilities/XQuartz.app. I just renamed it from XQuartz.app to X11.app and everything works fine, so far.