3 update with new findings
source | link

EDIT I noticed this seems to happen randomly. Sometimes, Time Machine will start to back up the 400+ GB. At other times, it performs a normal incremental backup. So, I am not sure the procedure listed below really has any effect. I'll leave the description there just in case...

When the external USB HD is connected, I now simply check Time Machine when it starts to backup. If it wants to backup the 400+GB, I simply "Skip" the backup. If not, I let it continue. Not a perfect solution by far, but it works for me.


I booted my Mac in safe mode to see if this would solve the problem. Alas, it did not. Afterwards, whether caused by the safe boot or not, Time Machine didn't "see" the external Data partition anymore, so it would only backup from the internal SSD (and the TM preferences windows no longer listed the WinData partition in the list of excluded items).

At that point I reset Time Machine's configuration, as described in James Pond's Full Reset of Time Machine:

  • switch off Time Machine in the preferences window
  • make sure no backup is running
  • connect external drives included in the backup
  • take a screenshot of the TM preferences (the exclusion list)
  • disconnect the backup disk
  • delete /Library/Preferences/com.apple.TimeMachine.plist
  • reboot your Mac
  • connect your backup disk
  • re-configure Time Machine

    • select your backup disk
    • copy the TM preferences from the screenshot

After this process, Time Machine sees my external Data disk again; Data and WinData are automatically included in the excluded items list. After removing Data from the list, Time Machine now properly creates incremental backups of Data again.

There was one small problem however. The new files added to Data recently (right before TM started to make huge backups) were not backed up. To solve this, the following worked:

  • move these new files to another disk
  • create a new backup (size near 0)
  • place the files pack
  • create a new backup

You can perhaps use tmutil compare to see which files were not backed up.

I booted my Mac in safe mode to see if this would solve the problem. Alas, it did not. Afterwards, whether caused by the safe boot or not, Time Machine didn't "see" the external Data partition anymore, so it would only backup from the internal SSD (and the TM preferences windows no longer listed the WinData partition in the list of excluded items).

At that point I reset Time Machine's configuration, as described in James Pond's Full Reset of Time Machine:

  • switch off Time Machine in the preferences window
  • make sure no backup is running
  • connect external drives included in the backup
  • take a screenshot of the TM preferences (the exclusion list)
  • disconnect the backup disk
  • delete /Library/Preferences/com.apple.TimeMachine.plist
  • reboot your Mac
  • connect your backup disk
  • re-configure Time Machine

    • select your backup disk
    • copy the TM preferences from the screenshot

After this process, Time Machine sees my external Data disk again; Data and WinData are automatically included in the excluded items list. After removing Data from the list, Time Machine now properly creates incremental backups of Data again.

There was one small problem however. The new files added to Data recently (right before TM started to make huge backups) were not backed up. To solve this, the following worked:

  • move these new files to another disk
  • create a new backup (size near 0)
  • place the files pack
  • create a new backup

You can perhaps use tmutil compare to see which files were not backed up.

EDIT I noticed this seems to happen randomly. Sometimes, Time Machine will start to back up the 400+ GB. At other times, it performs a normal incremental backup. So, I am not sure the procedure listed below really has any effect. I'll leave the description there just in case...

When the external USB HD is connected, I now simply check Time Machine when it starts to backup. If it wants to backup the 400+GB, I simply "Skip" the backup. If not, I let it continue. Not a perfect solution by far, but it works for me.


I booted my Mac in safe mode to see if this would solve the problem. Alas, it did not. Afterwards, whether caused by the safe boot or not, Time Machine didn't "see" the external Data partition anymore, so it would only backup from the internal SSD (and the TM preferences windows no longer listed the WinData partition in the list of excluded items).

At that point I reset Time Machine's configuration, as described in James Pond's Full Reset of Time Machine:

  • switch off Time Machine in the preferences window
  • make sure no backup is running
  • connect external drives included in the backup
  • take a screenshot of the TM preferences (the exclusion list)
  • disconnect the backup disk
  • delete /Library/Preferences/com.apple.TimeMachine.plist
  • reboot your Mac
  • connect your backup disk
  • re-configure Time Machine

    • select your backup disk
    • copy the TM preferences from the screenshot

After this process, Time Machine sees my external Data disk again; Data and WinData are automatically included in the excluded items list. After removing Data from the list, Time Machine now properly creates incremental backups of Data again.

There was one small problem however. The new files added to Data recently (right before TM started to make huge backups) were not backed up. To solve this, the following worked:

  • move these new files to another disk
  • create a new backup (size near 0)
  • place the files pack
  • create a new backup

You can perhaps use tmutil compare to see which files were not backed up.

2 rephrase
source | link

I booted my Mac in safe mode to see if this would solve the problem. Alas, it did not. Afterwards, whether caused by the safe boot or not, Time Machine didn't "see" the external Data partition anymore, so it would only backup from the internal SSD. The (and the TM preferences windows no longer listed the WinData partition in the list of excluded items).

At that point I tried to reset Time Machine's configuration, as described in James Pond's Full Reset of Time Machine:

  • switch off Time Machine in the preferences window
  • make sure no backup is running
  • connect external drives included in the backup
  • take a screenshot of the TM preferences (the exclusion list)
  • disconnect the backup disk
  • delete /Library/Preferences/com.apple.TimeMachine.plist
  • reboot your Mac
  • connect your backup disk
  • re-configure Time Machine

    • select your backup disk
    • copy the TM preferences from the screenshot

After this process, Time Machine sees my external Data disk again; Data and WinData are automatically included in the excluded items list. After removing Data from the list, Time Machine now properly creates incremental backups of Data again.

There was one small problem however. The new files added to Data recently (right before TM started to make huge backups) were not backed up. To solve this, the following worked:

  • move these new files to another disk
  • create a new backup (size near 0)
  • place the files pack
  • create a new backup

You can perhaps use tmutil compare to see which files were not backed up.

I booted my Mac in safe mode to see if this would solve the problem. Alas, it did not. Afterwards, whether caused by the safe boot or not, Time Machine didn't "see" the external Data partition anymore, so it would only backup from the internal SSD. The TM preferences windows no longer listed the WinData partition in the list of excluded items.

At that point I tried to reset Time Machine's configuration, as described in James Pond's Full Reset of Time Machine:

  • switch off Time Machine in the preferences window
  • make sure no backup is running
  • connect external drives included in the backup
  • take a screenshot of the TM preferences (the exclusion list)
  • disconnect the backup disk
  • delete /Library/Preferences/com.apple.TimeMachine.plist
  • reboot your Mac
  • connect your backup disk
  • re-configure Time Machine

    • select your backup disk
    • copy the TM preferences from the screenshot

After this process, Time Machine sees my external Data disk again; Data and WinData are automatically included in the excluded items list. After removing Data from the list, Time Machine now properly creates incremental backups of Data again.

There was one small problem however. The new files added to Data recently (right before TM started to make huge backups) were not backed up. To solve this, the following worked:

  • move these new files to another disk
  • create a new backup (size near 0)
  • place the files pack
  • create a new backup

You can perhaps use tmutil compare to see which files were not backed up.

I booted my Mac in safe mode to see if this would solve the problem. Alas, it did not. Afterwards, whether caused by the safe boot or not, Time Machine didn't "see" the external Data partition anymore, so it would only backup from the internal SSD (and the TM preferences windows no longer listed the WinData partition in the list of excluded items).

At that point I reset Time Machine's configuration, as described in James Pond's Full Reset of Time Machine:

  • switch off Time Machine in the preferences window
  • make sure no backup is running
  • connect external drives included in the backup
  • take a screenshot of the TM preferences (the exclusion list)
  • disconnect the backup disk
  • delete /Library/Preferences/com.apple.TimeMachine.plist
  • reboot your Mac
  • connect your backup disk
  • re-configure Time Machine

    • select your backup disk
    • copy the TM preferences from the screenshot

After this process, Time Machine sees my external Data disk again; Data and WinData are automatically included in the excluded items list. After removing Data from the list, Time Machine now properly creates incremental backups of Data again.

There was one small problem however. The new files added to Data recently (right before TM started to make huge backups) were not backed up. To solve this, the following worked:

  • move these new files to another disk
  • create a new backup (size near 0)
  • place the files pack
  • create a new backup

You can perhaps use tmutil compare to see which files were not backed up.

1
source | link

I booted my Mac in safe mode to see if this would solve the problem. Alas, it did not. Afterwards, whether caused by the safe boot or not, Time Machine didn't "see" the external Data partition anymore, so it would only backup from the internal SSD. The TM preferences windows no longer listed the WinData partition in the list of excluded items.

At that point I tried to reset Time Machine's configuration, as described in James Pond's Full Reset of Time Machine:

  • switch off Time Machine in the preferences window
  • make sure no backup is running
  • connect external drives included in the backup
  • take a screenshot of the TM preferences (the exclusion list)
  • disconnect the backup disk
  • delete /Library/Preferences/com.apple.TimeMachine.plist
  • reboot your Mac
  • connect your backup disk
  • re-configure Time Machine

    • select your backup disk
    • copy the TM preferences from the screenshot

After this process, Time Machine sees my external Data disk again; Data and WinData are automatically included in the excluded items list. After removing Data from the list, Time Machine now properly creates incremental backups of Data again.

There was one small problem however. The new files added to Data recently (right before TM started to make huge backups) were not backed up. To solve this, the following worked:

  • move these new files to another disk
  • create a new backup (size near 0)
  • place the files pack
  • create a new backup

You can perhaps use tmutil compare to see which files were not backed up.