We’re rewarding the question askers & reputations are being recalculated! Read more.
4 broken image fixed (click 'rendered output' to see the difference); for more info, see https://gist.github.com/Glorfindel83/9d954d34385d2ac2597bbe864466259f
source | link

This was supposed to be a comment, but it turned out too long.

It might be that the trackpad is slightly damaged so that the button is somehow pressed down constantly.

I have a black macbook that clicks every time I rest my hands anywhere near the area below the keyboard or around the trackpad. The plastic around that part of the case has kind of caved in and it affects the trackpad. If something similar has happened to your macbook, only that it is constantly pressing the button, you wouldn't be able to press any buttons with any mouse.

On my own macbook, all of this (the case caving in) started after almost the entire bottom edge of the top case was breaking off, like in the picture below, which is a common problem on many of the macbooks (picture through google).

Macbook broken plastic edge http://i18.tinypic.com/6f9w7tf.jpgMacbook broken plastic edge 

Disabling the internal trackpad while only using the keyboard

  • Open Spotlight. The keyboard shortcut for this is usually cmd+space.
  • Once in System Preferences you should be able to select "Accessibility" simply by starting to type it (or whatever it is called in the language on your macbook). Or you might have to press cmd+f first.
  • Navigate the Accessibility preference pane by shifting focus around to different tabs, buttons etc with combinations of tab and arrow keys.
    • When a checkbox is in focus, press space to check it.
  • The checkbox you are looking for is called something similar to Disable trackpad when external mouse is connected in the mouse and trackpad tab.

This was supposed to be a comment, but it turned out too long.

It might be that the trackpad is slightly damaged so that the button is somehow pressed down constantly.

I have a black macbook that clicks every time I rest my hands anywhere near the area below the keyboard or around the trackpad. The plastic around that part of the case has kind of caved in and it affects the trackpad. If something similar has happened to your macbook, only that it is constantly pressing the button, you wouldn't be able to press any buttons with any mouse.

On my own macbook, all of this (the case caving in) started after almost the entire bottom edge of the top case was breaking off, like in the picture below, which is a common problem on many of the macbooks (picture through google).

Macbook broken plastic edge http://i18.tinypic.com/6f9w7tf.jpg

Disabling the internal trackpad while only using the keyboard

  • Open Spotlight. The keyboard shortcut for this is usually cmd+space.
  • Once in System Preferences you should be able to select "Accessibility" simply by starting to type it (or whatever it is called in the language on your macbook). Or you might have to press cmd+f first.
  • Navigate the Accessibility preference pane by shifting focus around to different tabs, buttons etc with combinations of tab and arrow keys.
    • When a checkbox is in focus, press space to check it.
  • The checkbox you are looking for is called something similar to Disable trackpad when external mouse is connected in the mouse and trackpad tab.

This was supposed to be a comment, but it turned out too long.

It might be that the trackpad is slightly damaged so that the button is somehow pressed down constantly.

I have a black macbook that clicks every time I rest my hands anywhere near the area below the keyboard or around the trackpad. The plastic around that part of the case has kind of caved in and it affects the trackpad. If something similar has happened to your macbook, only that it is constantly pressing the button, you wouldn't be able to press any buttons with any mouse.

On my own macbook, all of this (the case caving in) started after almost the entire bottom edge of the top case was breaking off, like in the picture below, which is a common problem on many of the macbooks (picture through google).

Macbook broken plastic edge 

Disabling the internal trackpad while only using the keyboard

  • Open Spotlight. The keyboard shortcut for this is usually cmd+space.
  • Once in System Preferences you should be able to select "Accessibility" simply by starting to type it (or whatever it is called in the language on your macbook). Or you might have to press cmd+f first.
  • Navigate the Accessibility preference pane by shifting focus around to different tabs, buttons etc with combinations of tab and arrow keys.
    • When a checkbox is in focus, press space to check it.
  • The checkbox you are looking for is called something similar to Disable trackpad when external mouse is connected in the mouse and trackpad tab.
3 added 438 characters in body
source | link

This was supposed to be a comment, but it turned out too long.

It might be that the trackpad is slightly damaged so that the button is somehow pressed down constantly.

I have a black macbook that clicks every time I rest my hands anywhere near the area below the keyboard or around the trackpad. The plastic around that part of the case has kind of caved in and it affects the trackpad. If something similar has happened to your macbook, only that it is constantly pressing the button, you wouldn't be able to press any buttons with any mouse.

Maybe it's possible to disable the internal trackpad through trackpad through some settings and/or software? (you'd have to navigate with the keyboard to activate/install it)

Edit: On my own macbook, all of this (the case caving in) started after almost the entire bottom edge of the top case was breaking off, like in the picture below, which is a common problem on many of the macbooks (picture through google).

Macbook broken plastic edge http://i18.tinypic.com/6f9w7tf.jpg

Disabling the internal trackpad while only using the keyboard

  • Open Spotlight. The keyboard shortcut for this is usually cmd+space.
  • Once in System Preferences you should be able to select "Accessibility" simply by starting to type it (or whatever it is called in the language on your macbook). Or you might have to press cmd+f first.
  • Navigate the Accessibility preference pane by shifting focus around to different tabs, buttons etc with combinations of tab and arrow keys.
    • When a checkbox is in focus, press space to check it.
  • The checkbox you are looking for is called something similar to Disable trackpad when external mouse is connected in the mouse and trackpad tab.

This was supposed to be a comment, but it turned out too long.

It might be that the trackpad is slightly damaged so that the button is somehow pressed down constantly.

I have a black macbook that clicks every time I rest my hands anywhere near the area below the keyboard or around the trackpad. The plastic around that part of the case has kind of caved in and it affects the trackpad. If something similar has happened to your macbook, only that it is constantly pressing the button, you wouldn't be able to press any buttons with any mouse.

Maybe it's possible to disable the internal trackpad through trackpad through some settings and/or software? (you'd have to navigate with the keyboard to activate/install it)

Edit: On my macbook, all of this (the case caving in) started after almost the entire bottom edge of the top case was breaking off, like in the picture below, which is a common problem on many of the macbooks (picture through google).

Macbook broken plastic edge http://i18.tinypic.com/6f9w7tf.jpg

This was supposed to be a comment, but it turned out too long.

It might be that the trackpad is slightly damaged so that the button is somehow pressed down constantly.

I have a black macbook that clicks every time I rest my hands anywhere near the area below the keyboard or around the trackpad. The plastic around that part of the case has kind of caved in and it affects the trackpad. If something similar has happened to your macbook, only that it is constantly pressing the button, you wouldn't be able to press any buttons with any mouse.

On my own macbook, all of this (the case caving in) started after almost the entire bottom edge of the top case was breaking off, like in the picture below, which is a common problem on many of the macbooks (picture through google).

Macbook broken plastic edge http://i18.tinypic.com/6f9w7tf.jpg

Disabling the internal trackpad while only using the keyboard

  • Open Spotlight. The keyboard shortcut for this is usually cmd+space.
  • Once in System Preferences you should be able to select "Accessibility" simply by starting to type it (or whatever it is called in the language on your macbook). Or you might have to press cmd+f first.
  • Navigate the Accessibility preference pane by shifting focus around to different tabs, buttons etc with combinations of tab and arrow keys.
    • When a checkbox is in focus, press space to check it.
  • The checkbox you are looking for is called something similar to Disable trackpad when external mouse is connected in the mouse and trackpad tab.
2 added 522 characters in body
source | link

This was supposed to be a comment, but it turned out too long.

It might be that the trackpad is slightly damaged so that the button is somehow pressed down constantly.

I have a black macbook that clicks every time I rest my hands anywhere near the area below the keyboard or around the trackpad. The plastic around that part of the case has kind of caved in and it affects the trackpad. If something similar has happened to your macbook, only that it is constantly pressing the button, you wouldn't be able to press any buttons with any mouse.

Maybe it's possible to disable the internal trackpad through trackpad through some settings and/or software? (you'd have to navigate with the keyboard to activate/install it)

Edit: On my macbook, all of this (the case caving in) started after almost the entire bottom edge of the top case was breaking off, like in the picture below, which is a common problem on many of the macbooks (picture through google).

Macbook broken plastic edge http://i18.tinypic.com/6f9w7tf.jpg

This was supposed to be a comment, but it turned out too long.

It might be that the trackpad is slightly damaged so that the button is somehow pressed down constantly.

I have a black macbook that clicks every time I rest my hands anywhere near the area below the keyboard or around the trackpad. The plastic around that part of the case has kind of caved in and it affects the trackpad. If something similar has happened to your macbook, only that it is constantly pressing the button, you wouldn't be able to press any buttons with any mouse.

Maybe it's possible to disable the internal trackpad through trackpad through some settings and/or software? (you'd have to navigate with the keyboard to activate/install it)

This was supposed to be a comment, but it turned out too long.

It might be that the trackpad is slightly damaged so that the button is somehow pressed down constantly.

I have a black macbook that clicks every time I rest my hands anywhere near the area below the keyboard or around the trackpad. The plastic around that part of the case has kind of caved in and it affects the trackpad. If something similar has happened to your macbook, only that it is constantly pressing the button, you wouldn't be able to press any buttons with any mouse.

Maybe it's possible to disable the internal trackpad through trackpad through some settings and/or software? (you'd have to navigate with the keyboard to activate/install it)

Edit: On my macbook, all of this (the case caving in) started after almost the entire bottom edge of the top case was breaking off, like in the picture below, which is a common problem on many of the macbooks (picture through google).

Macbook broken plastic edge http://i18.tinypic.com/6f9w7tf.jpg

1
source | link