Podcast #128: We chat with Kent C Dodds about why he loves React and discuss what life was like in the dark days before Git. Listen now.
1
source | link

Disable Mavericks Spelling Autocorrection:

If you get frustrated when OS X 10.9 attempts to autocorrect the multiple technology words that it doesn’t recognize. You should be able to disable the autocorrection feature either globally or on a per application basis.

In theory you should be able to disable it globally or disable it only in certain applications. I have not found that the global disable actually seems to turn off the corrections in all applications though. this is most probably a bug that will be fixed in future Mavericks updates. It is helpful to disable it only in specific applications anyway.

Disable Spelling Autocorrection in all Applications:

  • Select Keyboards under System Preferences.
  • Under the Text tab uncheck correct spelling automatically.

Disable Autocorrection for a Specific Application:

  • Open the Apple application that you want autocorrection disabled.

  • Right-click (or ctrl-click) into any text field. From the context menu that appears, under Spelling and Grammar uncheck Correct Spelling Automatically.

enter image description here

Remember that various applications can handle spelling correction in multiple different ways. Many applications will maintain the consistency of OS X and have this option available when right-clicking (ctrl-clicking) a text field. Disabling autocorrection in Chrome, for example, is handled this way.

Other applications such as Firefox may require you hunting through the Preferences to disable the autocorrection feature.

    Post Made Community Wiki by Simon