Tag Info

New answers tagged

0

In TextEdit, the "opposite" of 'Wrap to Page' is Wrap to Window' It's never done text that extends beyond the visible area, left to right - for that you need something like BBEdit, or its freeware little brother TextWrangler.


-1

TextEdit doesn't work based on a page format. Since it doesn't know how wide your page is, it can't know when to wrap. You'll have to rely on something like Pages if you want to create a document based on a specific page format.


1

I had to disable two default shortcuts in the keyboard control panel (within System Preferences), that were designated for "Mission Control" and "Application Windows". They were getting in the way of me using this shortcut on Mac Word. Once that is disabled, you can use Shift + option/alt + up or down arrow.


0

TextEdit is a plain text editor it you first set the preferences for Format to "Plain text" before opening the file. Unfortunately Auto-Save has it drawbacks and if you do not have a proper backup of the file I'd say you're out of luck since the file was stored on a volume that could not store versions of the file.


1

You probably have the Recent items setting in System Preferences > General set to None:


1

For plaintext tabs, you don't need to replace the entire TextEdit app to change it. I looked at the source they changed and it provides the simpler answer: Open the Terminal and type defaults write com.apple.TextEdit "TabWidth" '4' Where '4' is the number of spaces a tab should be.


1

I'm the developer of an app called RTF Write which does exactly what you're looking for -- it also supports iCloud Drive and iCloud HandOff. It's free for iOS, the OS X version is $2.99. http://machsoftwaredesign.com/rtfwrite.html


4

It sounds like you are in rich text mode, so the editor is trying to save the file in non-plain text format. In general for css/html/code you want just plain text. In the "Format" menu, choose "Make Plain Text" then when you do a "Save As..." you should be able to just type whatever extension you need. EDIT -- As Tetsujin mentions, you do should uncheck ...


-1

If you really need to use TextEdit, simplest might be just to rename in the Finder afterwards. A CSS file is just a text file anyway, so it shouldn't upset anything. If you don't see the existing extension, then there's a pref in Finder menu > Preferences > Advanced to show all filename extensions, & also one just underneath to stop the Finder ...


2

Try with making the file to an Plain text file. It's under the Format tab (not in preferences). Have you taken a look at this? Apple support page



Top 50 recent answers are included