Hot answers tagged


To add to what gentmatt said, in the case you need to keep "Automatic by Language" because you happen to write in different languages, click on "Set Up…" in the list shown for the Spelling option. On the dialog box that appears, you can change the order for the languages. In my case, this is the order I chose. Now, I can write organize, and the word is ...


For OS X 10.8: System Preferences > Languages & Text > Text > Spelling Or for OS X 10.9 and later: System Preferences > Keyboard > Text > Spelling


Yes you can do it. Go to Settings > Keyboard > Text. Click the + sign on the bottom left to add a new text replacement. In the Replace column, put the word you want OS X to stop autocorrecting (no spaces are allowed). In the With column, put the exact same word you put in the Replace column. Voila. You're done. This has worked flawlessly for me ...


@emmby Whenever I see this question in the Internet or I ask it to someone .. people always misunderstand. Maybe because they are not Windows users, or they are Windows users who don't use the keyboard short-cuts. I always have the same question but I didn't find the answer yet. In windows, when we use the keyboard short-cuts we mostly use the Menu key ...


Mac OS X is compatible with the aff/dic open format dictionaries. All you need to do is to get one dictionary, and place it inside ~/Library/Spelling (you may have to create the directory). Get the Romanian dictionary from OpenOffice (or search for another language) Extract the file using The Unarchiver or rename the extension to .zip and extract it Move ...


The context menu can primarily be opened by a right mouse click only. But in the Universal Acces settings in the System Preferences we can control mouse keys by using the keyboard number pad. When activated, a right mouse click then can be achieved by Ctrl+5 on a keyboard with a numpad or Fn+Ctrl+i on a laptop. This will allow you to 'right-click' your word. ...


In Mavericks (10.9): System Preferences -> Keyboard -> Text -> Spelling or System Preferences -> Language & Region -> Keyboard Preferences -> Text -> Spelling


When typing the word, right-click it and choose Spelling & Grammar → Show Spelling and Grammar. This will bring up a window similar to the one below. It should say that the word was not found in the spelling dictionary. Click Learn to teach the word to the current dictionary.                     The file ~/Library/Spelling/LocalDictionary only ...


Removing words from the built-in dictionary is apparently more difficult than I thought it would be. Since your question is about how to prevent a particular misspelling of your co-worker's name, I have an alternate solution. You can add "Jennet" to Mac OS X's text substitution list in System Preferences -> Language & Text -> Text It will ...


Just right click in the working tab, select Spelling and uncheck the option "Check Spelling While Typing"


Inspector > Text > More > Language


If you hold the option key when you hit the space bar after typing the word autocorrect will not change the word.


Unfortunately, Apple hasn't relegated any control of auto-correct functions to the user (natively), and it isn't possible to add or remove words that it auto-corrects - other then using the shortcuts like you mentioned, which don't work for everything.


Not exclusively, but there is a tool that will mark spelling and other changes with a sound. As described in this answer, it is possible to detect the type of text field change that autocorrect uses programmatically. A sound is issued whenever any of the text changes - but this results in a lot of false positive "sounds" when autocorrect did not happen. A ...


If you're on Lion, you can turn on iOS-style spelling corrections in System Preferences under Language and Text. I don't always have luck noticing or reacting to these corrections while typing, but moving back over the misspelled word with your cursor will bring up the iOS-style popup and you can select the correct spelling with the down arrow and Return. A ...


Autocorrect with multiples languages (automatic by language) in Mavericks is broken. It does not underline all the bad written words. I have to select only 1 language to get it properly working.


If you have "correct spelling automatically" checked and it doesn't seem to be working, it might be because you're trying it in an unsupported application. E.g., I can use the feature in TextEdit and Pages but not, e.g., FireFox or SublimeText 2 (two of my most used apps). Tho I've spent way too much time looking, I haven't found any way of getting the ...


I have just spent some time with Mountain Lion after I added a custom dictionary (Afrikaans) to the ~/Library/Spelling folder (.dic and .aff). Findings: - If I set the "Spelling" in "System Preferences -> Language and text -> Text" to Afrikaans, the Afrikaans spell check works great. - If I set the "Spelling" to "Automatic by language" detection between ...


You should be able to get one at


Direct Answer Based on this link, I think the file you are looking for is: /private/var/mobile/Library/Keyboard/dynamic-text.dat Look at the link above to see full instructions. Original Post Slow Way To reject the suggested word, finish typing the word as you want it, then tap the x to dismiss the suggestion before typing anything else. Each ...


Old post, but by now a plugin exists that interfaces with OS X's built-in spell checker. See Haven't tried it myself yet, but will now!


On those slides where spell check is working in Spanish, select the text on those slides, then do the Tools » Language » English procedure you described above. Language is formatting applied to specific text. You can mix languages sentence by sentence (or even word by word) and if it is appropriately marked, spell check will follow.


Just to eliminate the possible culprits and short of reinstalling the Office. Please check in you PowerPoint in the Tools > Dictionary ... what language is indicated. If it's Spanish there try to set it to English and see if that helps. Probably after setting this you would better close entirely PowerPoint and then open it again.


Close to what you've asked, is to enable spelling auto-correction via: and then stay with your cursor at the end of a mispelled word, so you'll get an iOS style correction-suggestion: then with down-arrow and left/right-arrows you can choose the correct word.


You can't set it per application, but you can set it to support multiple languages and detect them automatically. To do so (in Lion - although I've been using this at least since Leopard), open System Preferences, go to Language & Text, select the Text tab, set Spelling to Automatic by Language, then open the Spelling dropdown again, select Setup... at ...


Spell check is a system service so by using the standard Mac control for a text box, chrome would magically get to use the service. Since chrome isn't programmed to use the standard control (they wrote their own implementation) - you would need to either get the chrome devs to change the code or you would need to change it yourself and re-compile your ...


Turns out I figured it out not long after typing this question! I just thought I'd experiment a little and found out how to do it. You change the language in Edit > Spelling > Spelling... and then reopen the document. That did it for me. I'm guessing it is a bug: I don't think having to close and open a document for language error display settings to make ...


This is actually an OS X issue and not a Pages issue since Pages uses the system dictionaries. You can use this support article to find the answer: You will see that Romanian spelling dictionary isn't something that ships with 10.11 - but you can add custom dictionaries under the spell check multiple ...


Renaming '/System/Library/Services/AppleSpell.service/Contents/Resources' did not work for me since that file doesn't seem to exist on this install (10.11). What did work was disabling it for the languages I usually write in, under System Preferences->Keyboard->Text->Spelling select menu. It's set to 'Automatic by Language' by default, choose 'Set up…' at ...


Settings ➙ General ➙ Keyboard: Turn off Auto-Correction Make sure Check Spelling (at the bottom of that same screen) is on Your iDevice will no longer automatically correct misspelled words, but it will highlight them for you. As far as I know this is the only way to have spell-checking on without the Auto-Correct feature.

Only top voted, non community-wiki answers of a minimum length are eligible