Tag Info

Hot answers tagged

11

The SMTP server is used to send mail. (Note: There are two locations you must paste you app-specific password, these instructions are for the 'sending' server, not the 'receiving' server') Go to Google and generate an app-specific password on this page. Now open Mail and go to Preferences > Accounts and select your Google account. At the bottom of the ...


8

SMTP daemons or servers are there to receive mail, not send it. In your example, mail is purely an email client, and it connects to whatever server is defined by the appropriate DNS MX record of bar.com, and has no requirement for a local server to be running in order to do so. However, depending on your mail setup, you may require to log into an outgoing ...


7

Simple! With a message composition window open in Apple Mail make the following menu selection: View > Reply-To Address Field That works for a message-by-message basis. If you want to apply all the time there's a hack you can do this via Terminal: defaults write com.apple.mail UserHeaders '{"Reply-To" = "reply-to@address"; }' More details can be found ...


5

The iOS version of Sparrow has just been released, and it contains this functionality. In the settings for email accounts you can set up aliases. You can also set up a custom signature and SMTP server for each alias:     When composing a message, by default it will be sent from your default alias. If you want to change this, tap the "From" ...


4

mail on OS X does actually seem to spawn Postfix long enough to deal with the mail, then tear it down a short time later. To see this in action, try telnet localhost 25 before the mail command, then immediately after, then wait 5 minutes and try it again. I am not sure this is actually a proper answer to the question because it doesn't explain how Postfix ...


3

Configuring additional outgoing mail servers from the Apple support websites has detail instructions: Go to Settings → Mail, Contacts, Calendars. Tap the Mail account for which you would like to change the settings. If your account is configured to sync Notes or other items, you may need to tap Account Info on the following screen as well. On the ...


3

Are you sure google isn't simply kicking you out after a month or so, because you have to refresh your two factor auth login? SMTP uses password authentication, and two factor auth sets up your account so that a password alone is not enough to access your account. I think this is unlikely to be a problem with mail.app, and deleting/re-creating the account ...


2

If you do not have a mail server running then there is nothing listening on port 25. Thus connection refused messages. So you need to run the mail server first. Also unless you work for Amazon your hostname is not .ant.amazon.com If you do ask your network admins. And this bit is a comment - I think you need to learn what telnet does before you start ...


1

The automatic domain selection in Mail based on the address is not possible but.... There is a setting in Mail, send from the account of the selected mail box. Means, if you create or reply to emails while in the Mailbox of the University it will use that account. However, if you create reply from your other account it will use that one. So all you ...


1

Don't set the 2 factor app-specific password you generate in Google on the Preferences → Account screen first. Go to the outgoing mail server settings first, set it there and come back to the main account setting and rekey that password. Surprisingly, this stupid gymnastics with the setting worked for me!


1

I figured out a workaround. I took the clue from my account that uses a custom port. For the accounts in which SSL doesn't work, I checked "Use custom port" and tried each of the standard port numbers until I found one that worked. With the custom port selected I can successfully disable SSL.


1

I think mail always uses local sendmail to send mails. At OSX sendmail is postfix. And it is definitely used. You can check the mail headers Received: by [Your-Mac] (Postfix, from userid .... Nevertheless it is not a good idea to use mail (or better postfix) like this. Best practice would be to use a Smart Host for your local Postfix to avoid often used ...


1

The old settings in Keychain can mess up the settings, actually observed earlier by jmegawarne. After I removed the old settings from Keychain, things started to work so clean up the old passwords from Keychain! And remember to input the app-specific password at least two times, not the Gmail password. Procedure remove all passwords and usernames ...


1

Login Items You can use your account's Login Items to automatically launch an application when logging in. System Preferences.app > Users and Groups > Login Items This though will only launch the application. A better solution is to find a GUI-less server and use launchd. postfix postfix is an open source SMTP server and it is included with Mac OS X. ...


1

You should be able to find that Information in /var/log/Mail.log and some more in /var/log/system.log.


1

In short, you can't accomplish what you're trying to do. In order to send/reply from a given address, you have to have that account set up and active in Mail. Without the account being active, the address you wish to use is not available. And setting up an SMTP server entry for the other account(s) will not bypass the primary issue since you would only be ...


1

To make new SMTP: Open Mail Preferences. Click on Accounts. If you have more than one click on one of them. In that widow look for Outgoing Mail server (SMTP). from the pick up select Edit SMTP server. In the new widow select the (+) and enter a description (name you like), and smtp.gmail.com Back in Account screen select that name.


1

afragen's method will work. You cannot modify the addresses if you set up the mail account as default "iCloud". Turn off mail in your iCloud settings then make a new mail account. Do not choose any of the default options for the listed services. Make a custom mail setup and you will be able enter everything manually as afragen has written. You will have to ...


1

One way to fix this is to install the official server app in order to re-enable this feature. You don't have to setup a mail server through the app. Just installing it will allow use of mailx through the command line. In the past, you had to buy and install OS X server as a separate product and now it's available from the App Store and gets installed on ...


1

I'm doubtful this is your issue, but note that the password for the SMTP server is configured independently from the incoming (IMAP) server. Double-check both are set to a valid app-specific password in Mail.app's settings.


1

(I apologize in advance for the wishy-washiness of this answer, but while I hope I'm on the right track, I do have some gaps in my knowledge.) The SMTP HELO message, while something of a relic, is supposed to allow the client to identify itself to a server. It is still required for the protocol and is generally expected to at least be a syntactically valid ...


1

FWIW I've been having this problem with my account since setting up two-factor-auth. I've had to reset my app-specific password for the GMail account on my mac profile several times. The most recent time I actually just needed to restart Mail.app though.


1

I don't know if this works for iCloud account but it works for regular email accounts, try the following. Go to Settings > Mail, Contacts, Calendars and then choose the iCloud mail account. If there is account information showing the Address as xxxx@me.com simply edit the field to be something like xxxx@me.com,myname@pobox.com When you send an email tap on ...



Only top voted, non community-wiki answers of a minimum length are eligible