Tag Info

Hot answers tagged

3

This should be solved changing the perms on that directory in the following way: $ cd /usr/local $ sudo chown -R <your-username>:<your-group-name> * If you don't know your group, just type id -g.


1

You're trying to change the ownership to owner "root" and group "lolajl", and "lolajl" isn't a legal group. Instead, try the following: sudo chown lolajl:staff .cpan which will change .cpan to be owned by user "lolajl" and group "staff".


1

I mentioned I owned the directory. I just found out that I actually owned the symbolic link to the directory. The user 'root' owned the directory. I chowned the directory and it works ok now. My guess is either the upgrade changed the owner of the directory or else it changed the permissions logic regarding symbolic links.


1

/Library and all subdirectories are owned by root I think upgrading the OS restored permissions. The directory that you own that the web server can see used to be ~/Sites but since Mountain Lion setting this up is more complex not just tick click on an option in system preferences e.g see this article (NB it looks reasonable but I have not tried it)



Only top voted, non community-wiki answers of a minimum length are eligible