Tag Info

Hot answers tagged

15

There is an easy but non-obvious way to do this. Assuming you've got Google sync set up, and you can see your one Google Calendar on your phone already, go to https://www.google.com/calendar/syncselect (it needs the www; it doesn't have to be on your iPhone). You'll see a list of devices you're syncing. Select your iPhone. On the next screen, you can ...


8

The Verge gave a good writeup recommending the Gmail App + CalDAV + CardDAV: http://www.theverge.com/2012/12/5/3732364/best-way-gmail-google-calendar-iphone-how-to The Gmail app solves both downsides you mention above. For CardDAV, it does a 15 min fetch, which is plenty good enough for me, so I don't see lack of push as being a real problem.


7

As far as I am aware, invoking iCal's "refresh" function, under the Calendar menu should do all server side communication and updates. Refresh will only update the calendar that hosts the event you currently have (or last had) selected. Refresh All will of course update all of your calendars. This should be a two-way process, and not just pulling down new ...


6

You can do this in the Calendar app. 1) Tap Calendars in the upper left corner: 2) Then tap Edit: 3) Select the calendar you want to change the colour of: 4) Pick the colour you want. If you want a more extensive selection than what's in the list, you need to do it from iCal on your Mac.


5

This is actually a default setting by Google that can be changed. To change this setting Go to your Google Calendar settings found in the top right under the gear icon. Select the Calendar tabs Click the Shared: Edit settings link for the calendar you want to edit. Select the Notifications tab Click the remove link next to the reminders you don't want. ...


4

You have to tell Google Calendar which calenders to sync by using Google Sync. It's a bit convoluted, but once it's set up you shouldn't have to do it again. I've done it and use Google Calendar and my iPad exactly as you describe. Google have the instructions here: Using Google Sync with iOS Calendar


4

The only way I've been able to do this (given that my employer will not allow my iPhone, etc. to connect to Exchange) is to have my primary calendar on my Google Calendar account be my work calendar, use the Google Calendar Sync application on my workstation at the office (always running) to sync from Outlook to Google (it supports only one calendar on ...


4

Google calendars other than your default calendar are treated as delegated calendars by iCal. To get them to open in the main screen go to iCal > Preferences > Accounts, select your google account, click the tab for Delegation, then check the boxes next to the calendars you want to display in your main calendar window. Now in the upper left hand corner of ...


4

On iOS 6 or earlier, my experience is that the easiest way to sync the calendars is, from within the Calendar App on the iPhone, tap the Calendar Button in the upper left corner. You now have a display with a grey Edit button in the upper left, A blue Done button in the upper right, and down at the bottom on the left is a white clockwise circular arrow. Tap ...


4

I started encountering a similar problem with my Google for Business account last week. Mail.app was okay but Calendar refused to sync, returning the error message that "Your calendar URL is not a location that supports this request." every time Calendar tried to sync. The solution was delete the account completely from System Preferences -> Mail, Contacts ...


4

Note this problem occurred for me after changing my Google password. On starting Calendar (a week or two after changing my password) it asked me for my password, as it couldn't access my Google account [expected behaviour]. I gave it my new password, and it seemed happy. HOWEVER the problem still remained. The fix is definitely like the other poster ...


4

To do so just: On iCal go to Preferences / Accounts. In the panel on the left, click the + button to add an account. Fill in the information, being: Account Type: Google. Although you can either use Automatic or CalDAV, and the System will detect the proper account type. Email Address: The email which you are using to log into the Calendar. The ...


3

You can set up a CalDAV account to sync all your Google calendars. The following information is provided by Google and can be found here: To sync with your device, follow these steps: Open the Settings application on your device's home screen. Open Mail, Contacts, Calendars. Select Add Account... Select Other. Select Add CalDAV Account. Enter your account ...


3

The approach I took was to sync my phone with the gmail calendar and then sync iCal with google calendar. I don't sync directly between phone and mac. I can add events on all three now and it will sync between all of them. edit: I've been asked to post up a screengrab, but it honestly isn't needed. I've seen the guides on setting up CalDav but it's ...


3

There's no official way to achieve this, however you can try a trick involving deactivating / reactivating calendars in a certain order until they match the colour you want.


3

No, the built-in Calendar application does not have a default alert setting. However, third-party apps can do it (and access the same calendars). For example, Quick Event (found here) looks like what you want.


3

BusyCal is the best answer I can give you if you only want to sync calendars to Google. I would also highly recommend SpanningSync which will also sync your Contacts in a much better and more reliable manner than Address Book will. (I have no affiliation with either company, and am a paying customer/user of both. I use/love BusyCal for my calendar, but ...


3

When MobileMe upgraded calendars - it removed the group option. iCloud does not have a folder/group data structure. BusyCal does let you create groups to manage your local view of iCloud (and other) calendars, but doesn't change iCloud's limitation to not have those groups appear on the server end of things. Their blog is an excellent source to get clear ...


3

You can choose which calendars to sync by going to: http://www.google.com/calendar/iphoneselect For more info, you can read Google's support doc about CalDAV Calendar Sync.


3

Yes, the best way to sync cross platform is via google. By far the easiest most care free way to sync all contacts, calendars, email etc is to have all Apple devices, this is how Apple meant for this service to be used. Google has done a good job of making this service available to people working on multiple platforms.


3

I am still looking for a solid answer. In the meantime, I have the following script running in AppleScript Editor. This script looks for the CalendarAgent every 15 seconds and kills the process. This renders calendar syncing unusable, but at least I can use my Mac again. I will let this run until I find a permanent solution. The script is: repeat ...


3

This appears to be an issue when Google is set up as a Microsoft Exchange account type (Google Sync) rather than the normal Gmail account in the Settings app. You can check that this is the case for you by opening the Settings app, going to the Mail, Contacts, Calendars section, and tapping on your Google account. If you see Exchange at the top of the page - ...


3

It often takes a few minutes for the cloud to sync, that's normal. I'd suggest double checking your phone to ensure your push settings are all set the way they ought to be. Since it's working on iPad, but not iPhone, it's my assumption something got funky in the settings and it's simply not being pushed to the cloud. easiest fix, delete your gmail and redo ...


3

You could use the combination of GeekTool and iCalBuddy (which you can install using Homebrew). On my desktop, it currently looks like this:


2

In iCal, add a new CalDAV account. Description: Google:you@gmail.com Username: you@gmail.com Password: yourpass SERVER SETTINGS Server Address: www.google.com Server Path: /calendar/dav/you@gmail.com/user/ Port: Auto Use SSL: CHecked Make sure you have sync enabled in iTunes.


2

You may be able to fix it by doing the following: Open the Settings on your iPhone Select "Mail, Contacts, Calendars" Scroll down to the Calendars section Select "Time Zone Support" Turn on Time Zone support Or maybe you want to turn time zone support off? It's a little confusing. Here's what Apple says: When Time Zone Support is on, Calendar ...


2

A partial-workaround is suggested on this Google thread: There is a workaround that solved the problem for me. The iPhone assigns calendar colours in this order: red, orange, blue, green, purple (then repeats that cycle). So the first step is to switch off Exchange syncing for Calendars in the iPhone settings then go into the ...


2

It's not a free service, but many people really like Apple's Mobile Me service, which consists of mail, calendar, photo sharing, etc. that all works over the web. You can do a two month trial for free and see how it goes. http://www.apple.com/mobileme/


2

This is a common error. The iCal auto setup has created an incorrect address for you. There should be no "slash" / at the end of the address i.e. it should be /calendar/dav/youremail@domain.com/user To fix it, go to Preferences / Accounts and change the address, removing the final / from the Server Path setting. AFAIK Lion no longer has this bug.


2

You can set the timezone in both the iPhone and Google Calendar. In Google Calendar, it's in the first page of the settings. In the iPhone, it's in Settings > Mail, Contacts, Calendar > Time Zone Support (at the bottom). You should set both in the same timezone, then see if it fixes the issue.



Only top voted, non community-wiki answers of a minimum length are eligible