Tag Info

New answers tagged

0

Option 1: just use /etc/launchd.conf Add a line like setenv PATH /Users/username/bin:/usr/local/bin:/usr/bin:/bin:/usr/sbin:/sbin to /etc/launchd.conf and restart to apply the changes. The default path is /usr/bin:/bin:/usr/sbin:/sbin. /etc/launchd.conf applies to all processes, which includes graphical applications, non-login shells, and programs ...


1

For those who don't like to have the hazzle with text files and editors, there is a GUI tool as well on github: https://github.com/hschmidt/EnvPane


1

If others search for how to set environment variables for processes started from a normal graphical login session, you can use /etc/launchd.conf. To for example add /usr/local/bin to the default path, run echo setenv PATH /usr/local/bin:/usr/bin:/bin:/usr/sbin:/sbin|sudo tee -a /etc/launchd.conf and restart to apply the changes. Another way to apply the ...


3

The correct file, prior to Mavericks, was ~/.MacOSX/environment.plist. This is no longer supported. In Darwin, and therefore in Mac OS X, the proper place to set these is in /etc/launchd.conf to apply to all processes; if relating to user shells specifically, use the appropriate shell files instead, depending on the shell in question. See the launchd.conf ...


1

I had a similar problem, specifically ~/.bashrc wasn't being sourced when I connected to my machine via SSH. I found that changing a configuration setting for SSHd did the trick. Perhaps your problem also lies with the SSH daemon? Modify the SSH service's configuration file as follows: # /etc/sshd_config PermitUserEnvironment yes Then restart the Remote ...



Top 50 recent answers are included