Tag Info

New answers tagged

1

To do this for just Emacs, use alias emacs=/usr/local/bin/emacs in your shell startup file which will make Emacs always run Homebrew emacs instead of whatever is first in your $PATH. But the better way to do this is to make your shell always look for Homebrew versions of commands first, by putting /usr/local/bin first, or at least early, in your $PATH. ...


1

This looks like an OS X bug coupled with different undefined behavior in Ruby and Emacs. The root cause is that when launching Emacs from Finder, OS X is passing the PATH environment variable to the process twice! I wrote a test case and submitted it to Apple's bug reporter (id 19801095). Here's my test case: #!/bin/bash mkdir -p ...


0

I had this problems some time ago. Turns out your Terminal app is configured to not use option as meta key. I'm running Mavericks and this is the default setting. All you have to do is open your Terminal app, click on the Terminal > Preferences > Settings > *Whatever profile you use* > Keyboard, mark the option "Use option as meta key"


2

Emacs from http://emacsformacosx.com/ comes with a recent etags: $find /Applications/Emacs.app -name etags\* /Applications/Emacs.app/Contents/MacOS/bin-i386-10_5/etags /Applications/Emacs.app/Contents/MacOS/bin-powerpc-10_4/etags /Applications/Emacs.app/Contents/MacOS/bin-x86_64-10_5/etags /Applications/Emacs.app/Contents/MacOS/bin-x86_64-10_7/etags ...



Top 50 recent answers are included