2
votes
1answer
1k views

How to update Python on a Mac with Unix commands

After giving up on doing a disk partition and getting Linux, I decided to try and install Python 3.3.2 on a 32 bit Intel Core 2 Duo iMac with OS X 10.6.8 Snow Leopard. I did pretty much everything the ...
0
votes
1answer
250 views

Rollback Python2.7 Installation

How do I reconfigure an installation of Python 2.7, on Snow Leopard, so that the OS uses the default 2.6 but leaves my 2.7 installation, and its installed modules, for use under virtualenv? Basically ...
1
vote
1answer
257 views

Installed additional python2.7 to Snow Leopard. What happens to modules I want to install?

I recently asked if I should upgrade python 2.6 to python 2.71 on my Mac (Snow Leopard). I was told to install 2.7 without removing 2.6. Done! Now I was wondering how the installation of new modules ...
2
votes
1answer
1k views

Snow Leopard: Current: python 2.6 - Desired: python 2.7

Is it possible to upgrade the native python version (2.6 on my Snow Leopard) to a more recent one? Or do I have to just install python 2.7 besides the current one?
0
votes
1answer
82 views

installing python2.4 on osx10.6?

I prefer installing stuff from their source and dont use package managers generally. Has anyone here tried building python2.4 from source here? If so, had any luck with the same?
3
votes
1answer
1k views

Error installing lxml on Mac Snow Leopard

I am getting what seems to be a common error when trying to install lxml on MacOS 10.6: Building lxml version 2.3. Building without Cython. Using build configuration of libxslt 1.1.24 ...